aboutsummaryrefslogtreecommitdiffstats
path: root/security/aescrypt/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/aescrypt/Makefile')
-rw-r--r--security/aescrypt/Makefile18
1 files changed, 14 insertions, 4 deletions
diff --git a/security/aescrypt/Makefile b/security/aescrypt/Makefile
index 1133e75bd5e6..da24852b10d9 100644
--- a/security/aescrypt/Makefile
+++ b/security/aescrypt/Makefile
@@ -7,17 +7,27 @@
PORTNAME= aescrypt
PORTVERSION= 0.7
+PORTREVISION= 1
CATEGORIES= security
-MASTER_SITES= http://aescrypt.sourceforge.net/
-MASTER_SITE_SUBDIR=aescrypt
+MASTER_SITES= SF
+
+PATCH_SITES= http://devel.ringlet.net/security/aescrypt/patches/ \
+ http://people.FreeBSD.org/~roam/ports/patches/security/aescrypt/
+PATCHFILES= aescrypt-0.7-roam-whopper-01.patch.gz
MAINTAINER= roam@FreeBSD.org
COMMENT= A command-line AES encryption/decryption suite
GNU_CONFIGURE= yes
+MAKE_ENV+= BINGRP=wheel
+
+MAN1= aescrypt.1 aesget.1
+MANCOMPRESSED= yes
+.if !defined(NOPORTDOCS)
post-install:
- ${MKDIR} ${PREFIX}/share/doc/aescrypt
- ${INSTALL_DATA} ${WRKSRC}/README.html ${PREFIX}/share/doc/aescrypt
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.html ${DOCSDIR}
+.endif
.include <bsd.port.mk>