aboutsummaryrefslogtreecommitdiffstats
path: root/security/botan/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/botan/Makefile')
-rw-r--r--security/botan/Makefile27
1 files changed, 21 insertions, 6 deletions
diff --git a/security/botan/Makefile b/security/botan/Makefile
index 05000001a4cf..4d8db3e5f9cb 100644
--- a/security/botan/Makefile
+++ b/security/botan/Makefile
@@ -8,6 +8,7 @@
PORTNAME= botan
PORTVERSION= 1.8.7
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://files.randombit.net/botan/v1.8/
DISTNAME= Botan-${PORTVERSION}
@@ -16,31 +17,41 @@ EXTRACT_SUFX= .tbz
MAINTAINER= lapo@lapo.it
COMMENT= A portable, easy to use, and efficient C++ crypto library
-OPTIONS= ECC "Enable ECC support" on
+OPTIONS= SSL "Enable OpenSSL engine" on \
+ GMP "Enable GMP engine" on \
+ ECC "Enable ECC support" on
USE_BZIP2= yes
USE_PYTHON_BUILD= yes
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= configure.py
-CONFIGURE_ARGS= --prefix=${PREFIX} --with-tr1-implementation=boost
+CONFIGURE_ARGS= --prefix=${PREFIX} --with-tr1-implementation=boost \
+ --with-bzip2 --with-zlib
USE_GMAKE= yes
MAKE_ARGS= CXX="${CXX}" LIB_OPT="${CXXFLAGS}"
USE_LDCONFIG= yes
-PLIST_SUB= SOVERSION=1.8.2
-
PORTDOCS= *
.include <bsd.port.options.mk>
+.if !defined(WITHOUT_SSL)
+USE_OPENSSL= yes
+CONFIGURE_ARGS+=--with-openssl
+.endif
+
+.if !defined(WITHOUT_GMP)
+LIB_DEPENDS+= gmp.7:${PORTSDIR}/math/libgmp4
+CONFIGURE_ARGS+=--with-gnump
+MAKE_ARGS+= LDFLAGS="-L${LOCALBASE}/lib"
+.endif
+
.if !defined(WITHOUT_ECC)
BUILD_DEPENDS+= ${LOCALBASE}/include/boost/tr1/memory.hpp:${PORTSDIR}/devel/boost-libs
CONFIGURE_ARGS+=--with-tr1-implementation=boost
CXXFLAGS+= -I${LOCALBASE}/include
-PLIST_SUB+= ECC=""
.else
CONFIGURE_ARGS+=--with-tr1-implementation=none
-PLIST_SUB+= ECC="@comment "
.endif
.if defined(NOPORTDOCS)
@@ -50,4 +61,8 @@ post-patch:
${WRKSRC}/src/build-data/makefile/unix_shr.in
.endif
+post-install:
+ @(cd ${PREFIX}; ${FIND} -s include/botan -not -type d) >> ${TMPPLIST}
+ @${ECHO_CMD} @dirrm include/botan >> ${TMPPLIST}
+
.include <bsd.port.mk>