aboutsummaryrefslogtreecommitdiffstats
path: root/security/clamav-devel
diff options
context:
space:
mode:
Diffstat (limited to 'security/clamav-devel')
-rw-r--r--security/clamav-devel/Makefile12
1 files changed, 4 insertions, 8 deletions
diff --git a/security/clamav-devel/Makefile b/security/clamav-devel/Makefile
index bfb38e60a431..fd7935b4156c 100644
--- a/security/clamav-devel/Makefile
+++ b/security/clamav-devel/Makefile
@@ -59,6 +59,10 @@ CPPFLAGS+= -I${LOCALBASE}/include \
LDFLAGS+= -L${LOCALBASE}/lib \
${PTHREAD_LIBS}
+# This port has a problem with -pthread,
+# force to use -lthr until it's not fixed.
+PTHREAD_LIBS= -lthr
+
MAN1= clamconf.1 \
clamscan.1 \
freshclam.1 \
@@ -103,14 +107,6 @@ PLIST_SUB+= CLAMAVUSER=${CLAMAVUSER} \
.include <bsd.port.pre.mk>
-# This port has a problem with -pthread,
-# force to use -lthr until it's not fixed.
-.if ${OSVERSION} >= 601000
-PTHREAD_LIBS= -lthr
-.else
-PTHREAD_LIBS= -lpthread
-.endif
-
.if defined(WITH_ARC)
RUN_DEPENDS+= arc:${PORTSDIR}/archivers/arc
.endif