aboutsummaryrefslogtreecommitdiffstats
path: root/security/courierpasswd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/courierpasswd/Makefile')
-rw-r--r--security/courierpasswd/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/security/courierpasswd/Makefile b/security/courierpasswd/Makefile
index 5edca04e66a7..924797189ab0 100644
--- a/security/courierpasswd/Makefile
+++ b/security/courierpasswd/Makefile
@@ -1,13 +1,10 @@
-# New ports collection makefile for: courierpasswd
-# Date created: 23th April 2006
-# Whom: Andrew St. Jean <andrew@arda.homeunix.net>
-#
+# Created by: Andrew St. Jean <andrew@arda.homeunix.net>
# $FreeBSD$
PORTNAME= courierpasswd
PORTVERSION= 1.1.2
CATEGORIES= security mail
-MASTER_SITES= http://www.arda.homeunix.net/store/
+MASTER_SITES= http://www.arda.homeunix.net/software-downloads/
MAINTAINER= andrew@arda.homeunix.net
COMMENT= User authentication and password changing utility
@@ -16,7 +13,7 @@ BUILD_DEPENDS= courierauthconfig:${PORTSDIR}/security/courier-authlib-base
RUN_DEPENDS= courierauthconfig:${PORTSDIR}/security/courier-authlib-base
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -26,6 +23,10 @@ CONFIGURE_ARGS+= --with-minuid=${MINUID}
MAN8= courierpasswd.8
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
pre-fetch:
@${ECHO} ""
@${ECHO} "#############################################################"
@@ -40,7 +41,7 @@ pre-fetch:
@${ECHO} ""
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/AUTHORS ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/ChangeLog ${DOCSDIR}