aboutsummaryrefslogtreecommitdiffstats
path: root/security/crank/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/crank/Makefile')
-rw-r--r--security/crank/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/security/crank/Makefile b/security/crank/Makefile
index cb725c14bb75..ae049ea876fe 100644
--- a/security/crank/Makefile
+++ b/security/crank/Makefile
@@ -7,15 +7,20 @@
#
PORTNAME= crank
-PORTVERSION= 0.1.4
+PORTVERSION= 0.2.1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
+LIB_DEPENDS= guile:${PORTSDIR}/lang/guile
+
USE_GTK= yes
GNU_CONFIGURE= yes
+GUILE_CONFIG= ${LOCALBASE}/bin/guile-config
+CONFIGURE_ENV= CFLAGS="${CFLAGS} `${GUILE_CONFIG} compile`" \
+ LDFLAGS="`${GUILE_CONFIG} link`"
USE_GMAKE= yes
.include <bsd.port.mk>