aboutsummaryrefslogtreecommitdiffstats
path: root/security/cyrus-sasl2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/cyrus-sasl2/Makefile')
-rw-r--r--security/cyrus-sasl2/Makefile120
1 files changed, 6 insertions, 114 deletions
diff --git a/security/cyrus-sasl2/Makefile b/security/cyrus-sasl2/Makefile
index 77661d3897a1..c0ce9340f809 100644
--- a/security/cyrus-sasl2/Makefile
+++ b/security/cyrus-sasl2/Makefile
@@ -1,42 +1,14 @@
# $FreeBSD$
-PORTNAME= cyrus-sasl
-PORTVERSION= 2.1.26
PORTREVISION= 12
-CATEGORIES= security ipv6
-MASTER_SITES= ftp://ftp.cyrusimap.org/cyrus-sasl/ \
- http://cyrusimap.org/releases/
-MAINTAINER= ume@FreeBSD.org
COMMENT= RFC 2222 SASL (Simple Authentication and Security Layer)
-LICENSE= BSD4CLAUSE
-LICENSE_FILE= ${WRKSRC}/COPYING
-
USES= cpe libtool:keepla pathfix perl5
USE_PERL5= patch
-USE_LDCONFIG= yes
-USE_OPENSSL= yes
-GNU_CONFIGURE= yes
-
-CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
- --with-configdir=${PREFIX}/lib/sasl2:${PREFIX}/etc/sasl2 \
- --with-plugindir=${PREFIX}/lib/sasl2 \
- --with-dbpath=${PREFIX}/etc/sasldb2 \
- --with-lib-subdir=lib \
- --with-pkgconfigdir=${PREFIX}/libdata/pkgconfig \
- --includedir=${PREFIX}/include \
- --enable-static \
- --enable-auth-sasldb \
- --with-rc4=openssl \
- --with-saslauthd=${SASLAUTHD_RUNPATH} \
- --disable-gssapi \
- --disable-krb4
-MAKE_ENV+= INSTALL_STRIP_FLAG=${STRIP}
-
-DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}2
-CPE_VENDOR= cmu
+CONFIGURE_ARGS+=--enable-auth-sasldb \
+ --with-saslauthd=${SASLAUTHD_RUNPATH}
NO_OPTIONS_SORT= yes
OPTIONS_DEFINE= ALWAYSTRUE AUTHDAEMOND DOCS KEEP_DB_OPEN \
@@ -48,14 +20,14 @@ OPTIONS_GROUP_PLUGIN= ANONYMOUS CRAM DIGEST LOGIN NTLM OTP PLAIN SCRAM
OPTIONS_DEFAULT= ANONYMOUS AUTHDAEMOND OBSOLETE_CRAM_ATTR CRAM DIGEST \
LOGIN NTLM OTP PLAIN SCRAM
OPTIONS_SUB= yes
-ALWAYSTRUE_DESC= the alwaystrue password verifier
+ALWAYSTRUE_DESC= Alwaystrue password verifier (discouraged)
ALWAYSTRUE_CONFIGURE_ENABLE=alwaystrue
-AUTHDAEMOND_DESC= use of authdaemon
+AUTHDAEMOND_DESC= Use of authdaemon
AUTHDAEMOND_CONFIGURE_ON=--with-authdaemond=/var/run/authdaemond/socket
AUTHDAEMOND_CONFIGURE_OFF=--with-authdaemond=no
KEEP_DB_OPEN_DESC= Keep handle to Berkeley DB open
KEEP_DB_OPEN_CONFIGURE_ENABLE=keep-db-open
-OBSOLETE_CRAM_ATTR_DESC=cmusaslsecretCRAM-MD5 property
+OBSOLETE_CRAM_ATTR_DESC=cmusaslsecretCRAM-MD5 auxprop property
OBSOLETE_CRAM_ATTR_CONFIGURE_OFF=--enable-obsolete_cram_attr=no
BDB_USE= BDB=yes
BDB_CONFIGURE_ON= --with-dblib=berkeley \
@@ -69,7 +41,6 @@ MYSQL_CONFIGURE_OFF= --without-mysql
PGSQL_USES= pgsql
PGSQL_CONFIGURE_ON= --with-pgsql=${LOCALBASE}
PGSQL_CONFIGURE_OFF= --without-pgsql
-SQLITE2_DESC= SQLite 2 database
SQLITE2_USE= SQLITE=2
SQLITE2_CONFIGURE_ON= --with-sqlite=${LOCALBASE}
SQLITE2_CONFIGURE_OFF= --without-sqlite
@@ -93,83 +64,4 @@ PLAIN_CONFIGURE_ENABLE= plain
SCRAM_DESC= SCRAM authentication
SCRAM_CONFIGURE_ENABLE= scram
-.include <bsd.port.pre.mk>
-
-.if ${PORT_OPTIONS:MBDB}
-INVALID_BDB_VER=2
-SASLDB_NAME= sasldb2
-.else
-SASLDB_NAME= sasldb2.db
-.endif
-
-.if ${PORT_OPTIONS:MMYSQL} || ${PORT_OPTIONS:MPGSQL} || \
- ${PORT_OPTIONS:MSQLITE2} || ${PORT_OPTIONS:MSQLITE3}
-CONFIGURE_ARGS+=--enable-sql
-.else
-SQL= "@comment "
-.endif
-
-.if ${ARCH} == "amd64"
-CPPFLAGS+= -fPIC
-.endif
-
-.if ${OPENSSLBASE} == /usr
-CONFIGURE_ARGS+=--with-openssl=yes
-.else
-CONFIGURE_ARGS+=--with-openssl=${OPENSSLBASE}
-.endif
-
-SASLAUTHD_RUNPATH?= /var/run/saslauthd
-
-CYRUS_USER?= cyrus
-CYRUS_GROUP?= cyrus
-
-DOCS= AUTHORS COPYING ChangeLog INSTALL INSTALL.TXT NEWS README
-
-DOC2= ONEWS TODO draft-burdis-cat-srp-sasl-xx.txt \
- draft-ietf-sasl-anon-xx.txt draft-ietf-sasl-crammd5-xx.txt \
- draft-ietf-sasl-gssapi-xx.txt draft-ietf-sasl-plain-xx.txt \
- draft-ietf-sasl-rfc2222bis-xx.txt draft-ietf-sasl-rfc2831bis-xx.txt \
- draft-ietf-sasl-saslprep-xx.txt draft-murchison-sasl-login-xx.txt \
- draft-newman-sasl-c-api-xx.txt rfc1321.txt rfc1939.txt rfc2104.txt \
- rfc2195.txt rfc2222.txt rfc2243.txt rfc2245.txt rfc2289.txt \
- rfc2444.txt rfc2595.txt rfc2831.txt rfc2945.txt rfc3174.txt \
- server-plugin-flow.fig testing.txt
-
-HTDOCS= advanced appconvert components gssapi index install macosx \
- mechanisms options plugprog programming readme sysadmin upgrading \
- windows
-
-SUB_FILES= pkg-deinstall pkg-install pkg-message
-SUB_LIST= CYRUS_USER=${CYRUS_USER} CYRUS_GROUP=${CYRUS_GROUP} \
- SASLDB=${SASLDB_NAME}
-
-PLIST_SUB+= PREFIX=${PREFIX} \
- SQL=${SQL} \
- DOCSDIR=${DOCSDIR:S/^${PREFIX}\///}
-
-post-patch:
-# Try to unbreak parallel (-jX) builds, part 1: make build commands atomic
- @${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${PERL} -w0pi.bak \
- -e 's/(^\@am__fastdepCC_TRUE\@.*?) \
- \n\@am__fastdepCC_TRUE\@\s+(.*?)$$/$$1 && $$2/mgx'
-# Part 2: prevent intermediate *.Tpo output files clash (use unique names)
- @${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${PERL} -wpi.bak \
- -e 's/\$$\*\.Tpo/$$&.$$./g'
-
-post-install-DOCS-on:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}/html
-.for f in ${DOCS}
- @${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
-.endfor
-.for f in ${DOC2}
- @${INSTALL_DATA} ${WRKSRC}/doc/${f} ${STAGEDIR}${DOCSDIR}
-.endfor
-.for f in ${HTDOCS}
- @${INSTALL_DATA} ${WRKSRC}/doc/${f}.html \
- ${STAGEDIR}${DOCSDIR}/html
-.endfor
- @${INSTALL_DATA} ${FILESDIR}/Sendmail.README \
- ${STAGEDIR}${DOCSDIR}
-
-.include <bsd.port.post.mk>
+.include "${.CURDIR}/../../security/cyrus-sasl2/Makefile.common"
cus2006-04-3011-2269/+2567 * Update to KOffice 1.5.0lofi2006-04-29113-327/+1414 * - Fix build on 4.Xpav2006-04-292-4/+39 * Bump PORTREVISION for bristuff removal.fjoe2006-04-273-0/+3 * - Update to 2.0garga2006-04-273-10/+9 * Update to 1.93erwin2006-04-263-5/+5 * - Remove bristuff support. Will be added later as a slave port.fjoe2006-04-266-36/+42 * - Broken on 4.X: does not compilepav2006-04-261-1/+7 * Change MAINTAINER address to @FreeBSD.orggrog2006-04-261-1/+1 * - Update to 0.1.6pav2006-04-262-7/+5 * - Update to 0.50pav2006-04-258-51/+132 * - Update to 4.2.27mnag2006-04-243-51/+79 * - Update i386 version to 2.9012.497tdb2006-04-243-16/+8 * Update to 2006dedwin2006-04-213-4/+5 * - Update to 1.10.6vs2006-04-202-10/+8 * Update to version 1.1.5markus2006-04-204-8/+8 * Fix plist issue on RELENG_4, libdata/ldconfig directories were onlyflz2006-04-181-1/+5 * Restore mbr as maintainer at his request. It seems I lost his mail replyinglinimon2006-04-181-1/+1 * Update to 1.53arved2006-04-182-4/+3 * Remove BROKEN= line, the port currently builds without problems.vd2006-04-171-2/+0 * Fix missing upclient.sh from SUB_FILESedwin2006-04-171-2/+2 * Update to version 0.12.15markus2006-04-162-4/+4 * Reset mph due to no response to email about status, and maintainer-timeouts.linimon2006-04-151-1/+1 * Reset mbr due to no answer to an email inquiry about his status, andlinimon2006-04-151-1/+1 * Reset kwm due to no response about email.linimon2006-04-151-1/+1 * Reset pat due to no response to email about his status.linimon2006-04-154-4/+4 * Reset petef due to no response to email. We hope to see him back sometime.linimon2006-04-152-2/+2 * Reset sf as maintainer due to no response to email messages.linimon2006-04-152-2/+2 * Reset vsevolod as maintainer due to unreponsiveness. We hope to see himlinimon2006-04-152-2/+2 * - Fix wrong patch.mnag2006-04-142-1/+2 * Pass maintainer-ship to the submitter of the latest update.ehaupt2006-04-131-2/+3 * - Update to 3.2.3ehaupt2006-04-122-8/+8 * Update to 1.37.tobez2006-04-122-4/+4 * - Upgrade to v3.7.jkoshy2006-04-093-22/+44 * Update to 1.0pre6hq2006-04-092-5/+5 * - use @dirrmtrydinoex2006-04-081-2/+2 * - Update to 0.37.4pav2006-04-055-46/+10 * Reset jeremy@external.org who has not responded to email asking aboutlinimon2006-04-051-1/+1 * - Add some messages in pkg-message that were missing.jmelo2006-04-051-1/+2 * - Update to version 1.1.4markus2006-04-036-18/+50 * BROKEN on 6.x: Does not compilekris2006-04-031-1/+7 * Use SUB_FILES for pkg-messageedwin2006-04-017-17/+9 * Reset phantom@ as maintainer as he has been inactive for more than one year.linimon2006-03-311-1/+1 * upgrade to 0.6.9ijliao2006-03-318-18/+211 * Update to KDE 3.5.2lofi2006-03-31173-2527/+1732 * define NO_PACKAGE when on the FreeBSD package building cluster.edwin2006-03-291-0/+6 * FreeBSD 4.x doesn't know about the country code AX.edwin2006-03-282-1/+18 * Update the zoneinfo files from ftp://elsie.nci.nih.gov/pub/ so thatedwin2006-03-276-0/+502 * o) File was not commited in first step, I don't know why?lkoeller2006-03-251-0/+19 * o) Fix problem that the app has no name, so the windowmanager could notlkoeller2006-03-251-1/+1 * Drop maintainershipmarkus2006-03-251-1/+1 * Update to version 0.12.14markus2006-03-253-4/+12 * Reset jedgar as maintainer; has not responded to email about status.linimon2006-03-242-2/+2 * - Correct mimetime directory namesmarkus2006-03-236-14/+14 * Fix incorrect $PORTNAME usage.kuriyama2006-03-228-12/+12 * - Grab maintainership.kuriyama2006-03-2236-348/+468 * - Fix MASTER_SITES, make fetchabletdb2006-03-212-4/+5 * - Fix MASTER_SITES, making port fetchable againtdb2006-03-211-2/+2 * - add USE_GNUSTEP_PREFIXdinoex2006-03-191-3/+1 * Reset maintainer at his request due to current lack of FreeBSD time.linimon2006-03-191-1/+1 * - Update to 2.0beta5pav2006-03-193-18/+6 * Clean up leftover mime.cache files, and add another MIME subdirectory.marcus2006-03-182-1/+4 * Update from 1.4.1 to 1.4.2 (bugfix release)vd2006-03-173-36/+4 * Update to 0.17.mezz2006-03-173-17/+43 * - Fix fetchingpav2006-03-161-1/+1 * Chase pear-Cache relocation.thierry2006-03-161-1/+2 * - Fix MASTER_SITESgarga2006-03-161-1/+1 * - Bring back bristuff support (bristuff-0.3.0-PRE-1l).fjoe2006-03-1512-126/+90 * Remove expired leaf ports:vd2006-03-156-2230/+0 * update to 3.36.1oliver2006-03-152-4/+4 * Mark IGNORE on 7.x: the configure script attempts to force a memorykris2006-03-112-2/+14 * Bump PORTREVISION on glib12/gtk12 consumer ports to ease the upgrade path.ade2006-03-0723-18/+23 * - Point MASTER_SITES to the new site and unbreak.garga2006-03-033-29/+26 * Post libtool-conversion fixupsade2006-02-262-2/+5 * BROKEN: Incorrect pkg-plistkris2006-02-262-0/+4 * Move maintainership to andreas@syndrom23.deedwin2006-02-241-1/+1 * Conversion to a single libtool environment.ade2006-02-2349-41/+188 * Back out PERL_(BUILD|RUN)_DEPENDS pending reimplementationkris2006-02-231-5/+5 * - Update to 1.3.bmnag2006-02-232-8/+9 * Update to version 0.12.11markus2006-02-233-4/+17 * - Update to 2.0.b.4garga2006-02-233-17/+31 * Avoid clobbering ${ARCH} variable for amd64 which resulted in this portlesi2006-02-212-13/+16 * Update search.cpan.org WWW: entries to have a trailing slash.fenner2006-02-212-2/+2 * Remove the FreeBSD KEYWORD from all rc.d scripts where it appears.dougb2006-02-213-3/+2 * - Fix problem with ancient make.flz2006-02-202-6/+6 * - Remove deprecated USE_REINPLACEtdb2006-02-191-6/+0 * Remove deprecated USE_REINPLACEehaupt2006-02-191-1/+0 * - added RUN_DEPENDSaaron2006-02-191-0/+1 * Adding port misc/p5-Geo-Cache, Oan object interface for GPS waypointsaaron2006-02-195-0/+44 * Adding port misc/p5-Acme-ButFirst, allowing you to do something, but do somet...aaron2006-02-185-0/+56 * - Fix MASTER_SITES [1]garga2006-02-182-14/+13 * Update to 0.7.7.1cjh2006-02-165-62/+47 * Add LATEST_LINK=globus2 and CONFLICT with globus4.brooks2006-02-151-0/+3 * Register CONFLICTS between ports that install bin/git.anholt2006-02-152-0/+4 * pre-install -> pre-su-install.sobomax2006-02-141-1/+1 * Unbreak - disable configure check for gnuplot.lawrance2006-02-132-3/+31 * BROKEN: Configure failskris2006-02-131-0/+2 * fix pkg-plistedwin2006-02-132-9/+11 * Fix plist.lofi2006-02-122-6/+0 * Fix detection of called/calling numbers when there is no calling number.lawrance2006-02-112-0/+28 * Change install location.lawrance2006-02-112-4/+5 * Update port: misc/tinderbox to 2.3.0 + enhancementsedwin2006-02-113-78/+80 * DEPRECATED is a string, not a bool.brooks2006-02-111-1/+1 * Now that I've committed a Globus Toolkit 4.0 port, mark this portbrooks2006-02-111-0/+3 * Pet portlint by using DATADIR macro in plist.novel2006-02-111-11/+10 * * Remove print/acroread - it has expired on 2006-01-03vd2006-02-101-2/+2 * - gdk-pixbuf and gtk12 are required only for xmms plugin, so dependnovel2006-02-091-7/+5 * This software has quite broken original Makefile, at least for us.yar2006-02-082-7/+6 * * Update misc/ossp-uuid from 1.4.0 to 1.4.1vd2006-02-072-5/+5 * Otter is an automated deduction system (theorem prover) forgarga2006-02-075-0/+386 * So the prerelease tarball for this got rerolled for release without thelofi2006-02-062-6/+6 * Remove expired port misc/tvguidevs2006-02-045-50/+0 * Update to KDE 3.5.1.lofi2006-02-01185-1093/+6835 * SHA256ifyedwin2006-02-017-3/+56 * SHA256ifyedwin2006-02-017-2/+7 * Populate newly create net-p2p category with these ports:pav2006-01-3113-250/+0 * Update misc/bsdiff to version 4.3, to match the version in the srccperciva2006-01-312-3/+4 * Update to 11.2krion2006-01-302-4/+4 * - Update to 2.1tdb2006-01-283-9/+7 * - Fix possibility of "infinite make fork" when "Registering install for ..."linimon2006-01-281-0/+1 * FreeBSD 3.x systems are no longer supported, so this code is moot. In anylinimon2006-01-274-16/+0 * * audio/marlin, devel/upnp, devel/upnp104mnag2006-01-275-2/+49 * - Fix typo in pkg-messagegarga2006-01-271-2/+2 * Update to a distfile that contains the Rules from "Legends of the Ferengi".erwin2006-01-262-5/+5 * Don't remove system directorieskris2006-01-261-12/+0 * Add missing USE_GETTEXTkris2006-01-261-0/+1 * Handle WITHOUT_X11 optionache2006-01-263-30/+51 * [1]:jylefort2006-01-263-7/+15 * Activate linm, mc-style terminal file manager.cjh2006-01-247-0/+149 * BROKEN when WITHOUT_X11: Broken dependencykris2006-01-241-0/+4 * Back out last change while problem is being investigated.linimon2006-01-241-2/+2 * - Extend CONFLICTSsem2006-01-231-1/+1 * An implementation of AT&T Research UNIX V8 newer(1)sem2006-01-234-0/+54 * Back out last change while the bug it introduced is being investigated.linimon2006-01-231-1/+1 * SHA256ifyedwin2006-01-22