aboutsummaryrefslogtreecommitdiffstats
path: root/security/f-prot
diff options
context:
space:
mode:
Diffstat (limited to 'security/f-prot')
-rw-r--r--security/f-prot/Makefile16
-rw-r--r--security/f-prot/pkg-plist61
2 files changed, 41 insertions, 36 deletions
diff --git a/security/f-prot/Makefile b/security/f-prot/Makefile
index 452b29cba405..05d918cb1ab2 100644
--- a/security/f-prot/Makefile
+++ b/security/f-prot/Makefile
@@ -15,7 +15,8 @@ DISTNAME= fp-freebsd-ws-${PORTVERSION}
MAINTAINER= tim@bishnet.net
COMMENT= F-Prot Antivirus for BSD Workstations
-RUN_DEPENDS= ${SITE_PERL}/HTTP/Request.pm:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= ${SITE_PERL}/HTTP/Request.pm:${PORTSDIR}/www/p5-libwww \
+ ${PREFIX}/f-prot/SIGN.DEF:${PORTSDIR}/security/f-prot-sig
NO_PACKAGE= Free for personal use only
NO_CDROM= Free for personal use only
@@ -29,8 +30,19 @@ MAN1= f-prot.1
ONLY_FOR_ARCHS= i386
do-install:
- cd ${WRKDIR} && ${TAR} -cf - f-prot | ${TAR} -xf - -C ${PREFIX}
+ cd ${WRKDIR} && ${TAR} --exclude man_pages \
+ --exclude doc_ws \
+ --exclude f-prot.sh \
+ --exclude *.DEF \
+ -cf - f-prot | ${TAR} -xf - -C ${PREFIX}
+
${INSTALL_SCRIPT} ${WRKSRC}/f-prot.sh ${PREFIX}/bin/f-prot
${INSTALL_MAN} ${WRKSRC}/man_pages/f-prot.1 ${MANPREFIX}/man/man1/
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${CP} -Rp ${WRKSRC}/doc_ws/* ${DOCSDIR}
+.endif
+
.include <bsd.port.mk>
diff --git a/security/f-prot/pkg-plist b/security/f-prot/pkg-plist
index 8658c12cf6c3..9ea9e0b58667 100644
--- a/security/f-prot/pkg-plist
+++ b/security/f-prot/pkg-plist
@@ -3,42 +3,35 @@ f-prot/CHANGES
f-prot/ENGLISH.TX0
f-prot/INSTALL.bsd_ws
f-prot/LICENSE
-f-prot/MACRO.DEF
f-prot/README
-f-prot/SIGN.DEF
-f-prot/SIGN2.DEF
-f-prot/doc_ws/add_info.html
-f-prot/doc_ws/auto_updt.html
-f-prot/doc_ws/comm_scan.html
-f-prot/doc_ws/index.html
-f-prot/doc_ws/inf_eicar.gif
-f-prot/doc_ws/info_options.html
-f-prot/doc_ws/inst_pro.html
-f-prot/doc_ws/license.html
-f-prot/doc_ws/loc_files.html
-f-prot/doc_ws/macro_scanning_options.html
-f-prot/doc_ws/main_feat.html
-f-prot/doc_ws/man_updt.html
-f-prot/doc_ws/norm_scan.gif
-f-prot/doc_ws/per_scan.html
-f-prot/doc_ws/reporting_options.html
-f-prot/doc_ws/scanning_options.html
-f-prot/doc_ws/screenshot.jpg
-f-prot/doc_ws/sys_req.html
-f-prot/doc_ws/test_eicar.html
-f-prot/doc_ws/test_inst.html
-f-prot/doc_ws/updater.html
-f-prot/doc_ws/updater_req.html
-f-prot/doc_ws/updt_macro.gif
-f-prot/doc_ws/updt_sign.gif
-f-prot/doc_ws/updt_signature.gif
f-prot/f-prot
-f-prot/f-prot.sh
f-prot/install-f-prot.pl
-f-prot/man_pages/check-updates.pl.8
-f-prot/man_pages/f-prot.1
f-prot/tools/check-updates.pl
-@dirrm f-prot/doc_ws
-@dirrm f-prot/man_pages
+%%PORTDOCS%%%%DOCSDIR%%/add_info.html
+%%PORTDOCS%%%%DOCSDIR%%/auto_updt.html
+%%PORTDOCS%%%%DOCSDIR%%/comm_scan.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/inf_eicar.gif
+%%PORTDOCS%%%%DOCSDIR%%/info_options.html
+%%PORTDOCS%%%%DOCSDIR%%/inst_pro.html
+%%PORTDOCS%%%%DOCSDIR%%/license.html
+%%PORTDOCS%%%%DOCSDIR%%/loc_files.html
+%%PORTDOCS%%%%DOCSDIR%%/macro_scanning_options.html
+%%PORTDOCS%%%%DOCSDIR%%/main_feat.html
+%%PORTDOCS%%%%DOCSDIR%%/man_updt.html
+%%PORTDOCS%%%%DOCSDIR%%/norm_scan.gif
+%%PORTDOCS%%%%DOCSDIR%%/per_scan.html
+%%PORTDOCS%%%%DOCSDIR%%/reporting_options.html
+%%PORTDOCS%%%%DOCSDIR%%/scanning_options.html
+%%PORTDOCS%%%%DOCSDIR%%/screenshot.jpg
+%%PORTDOCS%%%%DOCSDIR%%/sys_req.html
+%%PORTDOCS%%%%DOCSDIR%%/test_eicar.html
+%%PORTDOCS%%%%DOCSDIR%%/test_inst.html
+%%PORTDOCS%%%%DOCSDIR%%/updater.html
+%%PORTDOCS%%%%DOCSDIR%%/updater_req.html
+%%PORTDOCS%%%%DOCSDIR%%/updt_macro.gif
+%%PORTDOCS%%%%DOCSDIR%%/updt_sign.gif
+%%PORTDOCS%%%%DOCSDIR%%/updt_signature.gif
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm f-prot/tools
-@dirrm f-prot/
+@unexec rmdir f-prot 2> /dev/null || true