aboutsummaryrefslogtreecommitdiffstats
path: root/security/fastd-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/fastd-devel/Makefile')
-rw-r--r--security/fastd-devel/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/security/fastd-devel/Makefile b/security/fastd-devel/Makefile
new file mode 100644
index 000000000000..b6972ec53ad9
--- /dev/null
+++ b/security/fastd-devel/Makefile
@@ -0,0 +1,33 @@
+# $FreeBSD$
+
+PORTNAME= fastd
+PORTVERSION= 18.a.20151111
+CATEGORIES= security net
+MASTER_SITES= http://git.universe-factory.net/fastd/snapshot/
+PKGNAMESUFFIX= -devel
+DISTNAME= 999b87b80302dbc14e23ef3dff187b91dae7fab5
+
+MAINTAINER= crest_maintainer@rlwinm.de
+COMMENT= Fast and Secure Tunnelling Daemon
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYRIGHT
+
+LIB_DEPENDS= libjson-c.so:${PORTSDIR}/devel/json-c \
+ libsodium.so:${PORTSDIR}/security/libsodium \
+ libuecc.so:${PORTSDIR}/security/libuecc
+
+USES= bison cmake:outsource pkgconfig tar
+
+PKG_CONFIG_PATH= ${PREFIX}/lib/pkgconfig/
+CONFIGURE_ENV+= PKG_CONFIG_PATH=${PKG_CONFIG_PATH}
+
+USE_RC_SUBR= fastd_devel
+
+PLIST_FILES= bin/fastd-devel \
+ man/man1/fastd-devel.1.gz
+
+post-install:
+ ${INSTALL_MAN} ${WRKSRC}/doc/fastd.1 ${STAGEDIR}${PREFIX}/man/man1/fastd-devel.1
+
+.include <bsd.port.mk>