aboutsummaryrefslogtreecommitdiffstats
path: root/security/git-remote-gcrypt/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/git-remote-gcrypt/Makefile')
-rw-r--r--security/git-remote-gcrypt/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/security/git-remote-gcrypt/Makefile b/security/git-remote-gcrypt/Makefile
new file mode 100644
index 000000000000..77201075f10f
--- /dev/null
+++ b/security/git-remote-gcrypt/Makefile
@@ -0,0 +1,34 @@
+# Created by: Ashish SHUKLA <ashish@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= git-remote-gcrypt
+PORTVERSION= 1.0.2
+CATEGORIES= security
+
+MAINTAINER= ashish@FreeBSD.org
+COMMENT= PGP-encrypt git remotes
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= rst2man:textproc/py-docutils
+RUN_DEPENDS= rsync:net/rsync \
+ curl:ftp/curl \
+ gpg:security/gnupg
+
+USE_GITHUB= yes
+GH_ACCOUNT= spwhitton
+MAKE_ENV= DESTDIR=${STAGEDIR}
+
+NO_BUILD=
+
+PLIST_FILES= bin/${PORTNAME} \
+ man/man1/${PORTNAME}.1.gz
+
+post-extract:
+ @${REINPLACE_CMD} -e s,prefix/share/man,prefix/man, ${WRKSRC}/install.sh
+
+do-install:
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${WRKSRC}/install.sh
+
+.include <bsd.port.mk>