aboutsummaryrefslogtreecommitdiffstats
path: root/security/gnutls-devel/Makefile.man
diff options
context:
space:
mode:
Diffstat (limited to 'security/gnutls-devel/Makefile.man')
-rw-r--r--security/gnutls-devel/Makefile.man172
1 files changed, 93 insertions, 79 deletions
diff --git a/security/gnutls-devel/Makefile.man b/security/gnutls-devel/Makefile.man
index bb526e30ca7f..68e72477ea3b 100644
--- a/security/gnutls-devel/Makefile.man
+++ b/security/gnutls-devel/Makefile.man
@@ -5,9 +5,10 @@ INFO= gnutls
MAN1= \
certtool.1 \
- gnutls-cli.1 \
gnutls-cli-debug.1 \
+ gnutls-cli.1 \
gnutls-serv.1 \
+ p11tool.1 \
psktool.1 \
srptool.1
@@ -54,6 +55,7 @@ MAN3= \
gnutls_certificate_set_openpgp_keyring_file.3 \
gnutls_certificate_set_openpgp_keyring_mem.3 \
gnutls_certificate_set_params_function.3 \
+ gnutls_certificate_set_retrieve_function.3 \
gnutls_certificate_set_rsa_export_params.3 \
gnutls_certificate_set_verify_flags.3 \
gnutls_certificate_set_verify_function.3 \
@@ -78,8 +80,10 @@ MAN3= \
gnutls_certificate_verify_peers2.3 \
gnutls_check_version.3 \
gnutls_cipher_decrypt.3 \
+ gnutls_cipher_decrypt2.3 \
gnutls_cipher_deinit.3 \
gnutls_cipher_encrypt.3 \
+ gnutls_cipher_encrypt2.3 \
gnutls_cipher_get.3 \
gnutls_cipher_get_block_size.3 \
gnutls_cipher_get_id.3 \
@@ -141,6 +145,7 @@ MAN3= \
gnutls_global_set_log_function.3 \
gnutls_global_set_log_level.3 \
gnutls_global_set_mem_functions.3 \
+ gnutls_global_set_mutex.3 \
gnutls_handshake.3 \
gnutls_handshake_get_last_in.3 \
gnutls_handshake_get_last_out.3 \
@@ -234,6 +239,7 @@ MAN3= \
gnutls_openpgp_keyring_get_crt_count.3 \
gnutls_openpgp_keyring_import.3 \
gnutls_openpgp_keyring_init.3 \
+ gnutls_openpgp_privkey_decrypt_data.3 \
gnutls_openpgp_privkey_deinit.3 \
gnutls_openpgp_privkey_export.3 \
gnutls_openpgp_privkey_export_dsa_raw.3 \
@@ -255,6 +261,7 @@ MAN3= \
gnutls_openpgp_privkey_get_subkey_revoked_status.3 \
gnutls_openpgp_privkey_import.3 \
gnutls_openpgp_privkey_init.3 \
+ gnutls_openpgp_privkey_sec_param.3 \
gnutls_openpgp_privkey_set_preferred_key_id.3 \
gnutls_openpgp_privkey_sign_hash.3 \
gnutls_openpgp_send_cert.3 \
@@ -265,9 +272,42 @@ MAN3= \
gnutls_pem_base64_encode_alloc.3 \
gnutls_perror.3 \
gnutls_pk_algorithm_get_name.3 \
+ gnutls_pk_bits_to_sec_param.3 \
gnutls_pk_get_id.3 \
gnutls_pk_get_name.3 \
gnutls_pk_list.3 \
+ gnutls_pkcs11_add_provider.3 \
+ gnutls_pkcs11_copy_secret_key.3 \
+ gnutls_pkcs11_copy_x509_crt.3 \
+ gnutls_pkcs11_copy_x509_privkey.3 \
+ gnutls_pkcs11_deinit.3 \
+ gnutls_pkcs11_delete_url.3 \
+ gnutls_pkcs11_init.3 \
+ gnutls_pkcs11_obj_deinit.3 \
+ gnutls_pkcs11_obj_export.3 \
+ gnutls_pkcs11_obj_export_url.3 \
+ gnutls_pkcs11_obj_get_info.3 \
+ gnutls_pkcs11_obj_get_type.3 \
+ gnutls_pkcs11_obj_import_url.3 \
+ gnutls_pkcs11_obj_init.3 \
+ gnutls_pkcs11_obj_list_import_url.3 \
+ gnutls_pkcs11_privkey_decrypt_data.3 \
+ gnutls_pkcs11_privkey_deinit.3 \
+ gnutls_pkcs11_privkey_export_url.3 \
+ gnutls_pkcs11_privkey_get_info.3 \
+ gnutls_pkcs11_privkey_get_pk_algorithm.3 \
+ gnutls_pkcs11_privkey_import_url.3 \
+ gnutls_pkcs11_privkey_init.3 \
+ gnutls_pkcs11_privkey_sign_data.3 \
+ gnutls_pkcs11_privkey_sign_hash.3 \
+ gnutls_pkcs11_set_pin_function.3 \
+ gnutls_pkcs11_set_token_function.3 \
+ gnutls_pkcs11_token_get_flags.3 \
+ gnutls_pkcs11_token_get_info.3 \
+ gnutls_pkcs11_token_get_mechanism.3 \
+ gnutls_pkcs11_token_get_url.3 \
+ gnutls_pkcs11_token_init.3 \
+ gnutls_pkcs11_token_set_pin.3 \
gnutls_pkcs12_bag_decrypt.3 \
gnutls_pkcs12_bag_deinit.3 \
gnutls_pkcs12_bag_encrypt.3 \
@@ -310,6 +350,16 @@ MAN3= \
gnutls_priority_init.3 \
gnutls_priority_set.3 \
gnutls_priority_set_direct.3 \
+ gnutls_privkey_decrypt_data.3 \
+ gnutls_privkey_deinit.3 \
+ gnutls_privkey_get_pk_algorithm.3 \
+ gnutls_privkey_get_type.3 \
+ gnutls_privkey_import_openpgp.3 \
+ gnutls_privkey_import_pkcs11.3 \
+ gnutls_privkey_import_x509.3 \
+ gnutls_privkey_init.3 \
+ gnutls_privkey_sign_data.3 \
+ gnutls_privkey_sign_hash.3 \
gnutls_protocol_get_id.3 \
gnutls_protocol_get_name.3 \
gnutls_protocol_get_version.3 \
@@ -330,6 +380,25 @@ MAN3= \
gnutls_psk_set_server_credentials_hint.3 \
gnutls_psk_set_server_dh_params.3 \
gnutls_psk_set_server_params_function.3 \
+ gnutls_pubkey_deinit.3 \
+ gnutls_pubkey_export.3 \
+ gnutls_pubkey_get_key_id.3 \
+ gnutls_pubkey_get_key_usage.3 \
+ gnutls_pubkey_get_pk_algorithm.3 \
+ gnutls_pubkey_get_pk_dsa_raw.3 \
+ gnutls_pubkey_get_pk_rsa_raw.3 \
+ gnutls_pubkey_get_preferred_hash_algorithm.3 \
+ gnutls_pubkey_get_verify_algorithm.3 \
+ gnutls_pubkey_import.3 \
+ gnutls_pubkey_import_dsa_raw.3 \
+ gnutls_pubkey_import_openpgp.3 \
+ gnutls_pubkey_import_pkcs11.3 \
+ gnutls_pubkey_import_pkcs11_url.3 \
+ gnutls_pubkey_import_rsa_raw.3 \
+ gnutls_pubkey_import_x509.3 \
+ gnutls_pubkey_init.3 \
+ gnutls_pubkey_set_key_usage.3 \
+ gnutls_pubkey_verify_hash.3 \
gnutls_record_check_pending.3 \
gnutls_record_disable_padding.3 \
gnutls_record_get_direction.3 \
@@ -339,6 +408,7 @@ MAN3= \
gnutls_record_set_max_size.3 \
gnutls_register_md5_handler.3 \
gnutls_rehandshake.3 \
+ gnutls_rnd.3 \
gnutls_rsa_export_get_modulus_bits.3 \
gnutls_rsa_export_get_pubkey.3 \
gnutls_rsa_params_cpy.3 \
@@ -350,8 +420,11 @@ MAN3= \
gnutls_rsa_params_import_raw.3 \
gnutls_rsa_params_init.3 \
gnutls_safe_renegotiation_status.3 \
+ gnutls_sec_param_get_name.3 \
+ gnutls_sec_param_to_pk_bits.3 \
gnutls_server_name_get.3 \
gnutls_server_name_set.3 \
+ gnutls_session_channel_binding.3 \
gnutls_session_enable_compatibility_mode.3 \
gnutls_session_get_client_random.3 \
gnutls_session_get_data.3 \
@@ -397,12 +470,14 @@ MAN3= \
gnutls_transport_get_ptr.3 \
gnutls_transport_get_ptr2.3 \
gnutls_transport_set_errno.3 \
+ gnutls_transport_set_errno_function.3 \
gnutls_transport_set_global_errno.3 \
gnutls_transport_set_lowat.3 \
gnutls_transport_set_ptr.3 \
gnutls_transport_set_ptr2.3 \
gnutls_transport_set_pull_function.3 \
gnutls_transport_set_push_function.3 \
+ gnutls_transport_set_push_function2.3 \
gnutls_x509_crl_check_issuer.3 \
gnutls_x509_crl_deinit.3 \
gnutls_x509_crl_export.3 \
@@ -424,6 +499,7 @@ MAN3= \
gnutls_x509_crl_import.3 \
gnutls_x509_crl_init.3 \
gnutls_x509_crl_print.3 \
+ gnutls_x509_crl_privkey_sign.3 \
gnutls_x509_crl_set_authority_key_id.3 \
gnutls_x509_crl_set_crt.3 \
gnutls_x509_crl_set_crt_serial.3 \
@@ -452,12 +528,14 @@ MAN3= \
gnutls_x509_crq_get_key_rsa_raw.3 \
gnutls_x509_crq_get_key_usage.3 \
gnutls_x509_crq_get_pk_algorithm.3 \
+ gnutls_x509_crq_get_preferred_hash_algorithm.3 \
gnutls_x509_crq_get_subject_alt_name.3 \
gnutls_x509_crq_get_subject_alt_othername_oid.3 \
gnutls_x509_crq_get_version.3 \
gnutls_x509_crq_import.3 \
gnutls_x509_crq_init.3 \
gnutls_x509_crq_print.3 \
+ gnutls_x509_crq_privkey_sign.3 \
gnutls_x509_crq_set_attribute_by_oid.3 \
gnutls_x509_crq_set_basic_constraints.3 \
gnutls_x509_crq_set_challenge_password.3 \
@@ -466,6 +544,7 @@ MAN3= \
gnutls_x509_crq_set_key_purpose_oid.3 \
gnutls_x509_crq_set_key_rsa_raw.3 \
gnutls_x509_crq_set_key_usage.3 \
+ gnutls_x509_crq_set_pubkey.3 \
gnutls_x509_crq_set_subject_alt_name.3 \
gnutls_x509_crq_set_version.3 \
gnutls_x509_crq_sign.3 \
@@ -497,12 +576,14 @@ MAN3= \
gnutls_x509_crt_get_issuer_dn.3 \
gnutls_x509_crt_get_issuer_dn_by_oid.3 \
gnutls_x509_crt_get_issuer_dn_oid.3 \
+ gnutls_x509_crt_get_issuer_unique_id.3 \
gnutls_x509_crt_get_key_id.3 \
gnutls_x509_crt_get_key_purpose_oid.3 \
gnutls_x509_crt_get_key_usage.3 \
gnutls_x509_crt_get_pk_algorithm.3 \
gnutls_x509_crt_get_pk_dsa_raw.3 \
gnutls_x509_crt_get_pk_rsa_raw.3 \
+ gnutls_x509_crt_get_preferred_hash_algorithm.3 \
gnutls_x509_crt_get_proxy.3 \
gnutls_x509_crt_get_raw_dn.3 \
gnutls_x509_crt_get_raw_issuer_dn.3 \
@@ -514,13 +595,18 @@ MAN3= \
gnutls_x509_crt_get_subject_alt_name2.3 \
gnutls_x509_crt_get_subject_alt_othername_oid.3 \
gnutls_x509_crt_get_subject_key_id.3 \
+ gnutls_x509_crt_get_subject_unique_id.3 \
gnutls_x509_crt_get_verify_algorithm.3 \
gnutls_x509_crt_get_version.3 \
gnutls_x509_crt_import.3 \
+ gnutls_x509_crt_import_pkcs11.3 \
+ gnutls_x509_crt_import_pkcs11_url.3 \
gnutls_x509_crt_init.3 \
gnutls_x509_crt_list_import.3 \
+ gnutls_x509_crt_list_import_pkcs11.3 \
gnutls_x509_crt_list_verify.3 \
gnutls_x509_crt_print.3 \
+ gnutls_x509_crt_privkey_sign.3 \
gnutls_x509_crt_set_activation_time.3 \
gnutls_x509_crt_set_authority_key_id.3 \
gnutls_x509_crt_set_basic_constraints.3 \
@@ -538,6 +624,7 @@ MAN3= \
gnutls_x509_crt_set_key_usage.3 \
gnutls_x509_crt_set_proxy.3 \
gnutls_x509_crt_set_proxy_dn.3 \
+ gnutls_x509_crt_set_pubkey.3 \
gnutls_x509_crt_set_serial.3 \
gnutls_x509_crt_set_subject_alt_name.3 \
gnutls_x509_crt_set_subject_alternative_name.3 \
@@ -560,6 +647,7 @@ MAN3= \
gnutls_x509_privkey_export_dsa_raw.3 \
gnutls_x509_privkey_export_pkcs8.3 \
gnutls_x509_privkey_export_rsa_raw.3 \
+ gnutls_x509_privkey_export_rsa_raw2.3 \
gnutls_x509_privkey_fix.3 \
gnutls_x509_privkey_generate.3 \
gnutls_x509_privkey_get_key_id.3 \
@@ -568,87 +656,13 @@ MAN3= \
gnutls_x509_privkey_import_dsa_raw.3 \
gnutls_x509_privkey_import_pkcs8.3 \
gnutls_x509_privkey_import_rsa_raw.3 \
+ gnutls_x509_privkey_import_rsa_raw2.3 \
gnutls_x509_privkey_init.3 \
+ gnutls_x509_privkey_sec_param.3 \
gnutls_x509_privkey_sign_data.3 \
+ gnutls_x509_privkey_sign_data2.3 \
gnutls_x509_privkey_sign_hash.3 \
gnutls_x509_privkey_verify_data.3 \
gnutls_x509_rdn_get.3 \
gnutls_x509_rdn_get_by_oid.3 \
- gnutls_x509_rdn_get_oid.3 \
- gnutls_certificate_set_retrieve_function.3 \
- gnutls_global_set_mutex.3 \
- gnutls_openpgp_privkey_decrypt_data.3 \
- gnutls_pk_bits_to_sec_param.3 \
- gnutls_pkcs11_add_provider.3 \
- gnutls_pkcs11_copy_x509_crt.3 \
- gnutls_pkcs11_copy_x509_privkey.3 \
- gnutls_pkcs11_deinit.3 \
- gnutls_pkcs11_delete_url.3 \
- gnutls_pkcs11_init.3 \
- gnutls_pkcs11_obj_deinit.3 \
- gnutls_pkcs11_obj_export.3 \
- gnutls_pkcs11_obj_export_url.3 \
- gnutls_pkcs11_obj_get_info.3 \
- gnutls_pkcs11_obj_get_type.3 \
- gnutls_pkcs11_obj_import_url.3 \
- gnutls_pkcs11_obj_init.3 \
- gnutls_pkcs11_obj_list_import_url.3 \
- gnutls_pkcs11_privkey_decrypt_data.3 \
- gnutls_pkcs11_privkey_deinit.3 \
- gnutls_pkcs11_privkey_export_url.3 \
- gnutls_pkcs11_privkey_get_info.3 \
- gnutls_pkcs11_privkey_get_pk_algorithm.3 \
- gnutls_pkcs11_privkey_import_url.3 \
- gnutls_pkcs11_privkey_init.3 \
- gnutls_pkcs11_privkey_sign_data.3 \
- gnutls_pkcs11_privkey_sign_hash.3 \
- gnutls_pkcs11_set_pin_function.3 \
- gnutls_pkcs11_set_token_function.3 \
- gnutls_pkcs11_token_get_flags.3 \
- gnutls_pkcs11_token_get_info.3 \
- gnutls_pkcs11_token_get_url.3 \
- gnutls_privkey_decrypt_data.3 \
- gnutls_privkey_deinit.3 \
- gnutls_privkey_get_pk_algorithm.3 \
- gnutls_privkey_get_type.3 \
- gnutls_privkey_import_openpgp.3 \
- gnutls_privkey_import_pkcs11.3 \
- gnutls_privkey_import_x509.3 \
- gnutls_privkey_init.3 \
- gnutls_privkey_sign_data.3 \
- gnutls_privkey_sign_hash.3 \
- gnutls_pubkey_deinit.3 \
- gnutls_pubkey_export.3 \
- gnutls_pubkey_get_key_id.3 \
- gnutls_pubkey_get_key_usage.3 \
- gnutls_pubkey_get_pk_algorithm.3 \
- gnutls_pubkey_get_pk_dsa_raw.3 \
- gnutls_pubkey_get_pk_rsa_raw.3 \
- gnutls_pubkey_get_preferred_hash_algorithm.3 \
- gnutls_pubkey_get_verify_algorithm.3 \
- gnutls_pubkey_import.3 \
- gnutls_pubkey_import_dsa_raw.3 \
- gnutls_pubkey_import_openpgp.3 \
- gnutls_pubkey_import_pkcs11.3 \
- gnutls_pubkey_import_pkcs11_url.3 \
- gnutls_pubkey_import_rsa_raw.3 \
- gnutls_pubkey_import_x509.3 \
- gnutls_pubkey_init.3 \
- gnutls_pubkey_set_key_usage.3 \
- gnutls_pubkey_verify_hash.3 \
- gnutls_rnd.3 \
- gnutls_sec_param_get_name.3 \
- gnutls_sec_param_to_pk_bits.3 \
- gnutls_x509_crl_privkey_sign.3 \
- gnutls_x509_crq_get_preferred_hash_algorithm.3 \
- gnutls_x509_crq_privkey_sign.3 \
- gnutls_x509_crq_set_pubkey.3 \
- gnutls_x509_crt_get_preferred_hash_algorithm.3 \
- gnutls_x509_crt_import_pkcs11.3 \
- gnutls_x509_crt_import_pkcs11_url.3 \
- gnutls_x509_crt_list_import_pkcs11.3 \
- gnutls_x509_crt_privkey_sign.3 \
- gnutls_x509_crt_set_pubkey.3 \
- gnutls_x509_privkey_export_rsa_raw2.3 \
- gnutls_x509_privkey_import_rsa_raw2.3 \
- gnutls_x509_privkey_sign_data2.3
+ gnutls_x509_rdn_get_oid.3