aboutsummaryrefslogtreecommitdiffstats
path: root/security/gstreamer1-plugins-dtls/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/gstreamer1-plugins-dtls/Makefile')
-rw-r--r--security/gstreamer1-plugins-dtls/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/security/gstreamer1-plugins-dtls/Makefile b/security/gstreamer1-plugins-dtls/Makefile
new file mode 100644
index 000000000000..3a25177abdcb
--- /dev/null
+++ b/security/gstreamer1-plugins-dtls/Makefile
@@ -0,0 +1,18 @@
+# $FreeBSD$
+
+PORTREVISION= 0
+CATEGORIES= security
+
+COMMENT= Gstreamer Datagram TLS (dtls) plugin
+
+GST_PLUGIN= dtls
+DIST= bad
+
+# we don't have a way to specify this in ${MASTERDIR}/Makefile.common
+USE_OPENSSL= yes
+CONFIGURE_ENV= DTLS_CFLAGS="-I${OPENSSLINC}" \
+ DTLS_LIBS="-L${OPENSSLLIB} -lcrypto -lssl"
+
+MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer1-plugins
+
+.include "${MASTERDIR}/Makefile"