aboutsummaryrefslogtreecommitdiffstats
path: root/security/hs-cryptocipher/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/hs-cryptocipher/Makefile')
-rw-r--r--security/hs-cryptocipher/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/security/hs-cryptocipher/Makefile b/security/hs-cryptocipher/Makefile
new file mode 100644
index 000000000000..393ff99e4347
--- /dev/null
+++ b/security/hs-cryptocipher/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: hs-cryptocipher
+# Date created: November 19, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= cryptocipher
+PORTVERSION= 0.3.0
+CATEGORIES= security haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Symmetrical Block, Stream, and PubKey Ciphers
+
+LICENSE= BSD
+
+CABAL_SETUP= Setup.hs
+USE_CABAL= cereal crypto-api>=0.5 crypto-pubkey-types primitive tagged \
+ vector>=0.7
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>