aboutsummaryrefslogtreecommitdiffstats
path: root/security/libargon2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/libargon2/Makefile')
-rw-r--r--security/libargon2/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/security/libargon2/Makefile b/security/libargon2/Makefile
new file mode 100644
index 000000000000..782416a860a9
--- /dev/null
+++ b/security/libargon2/Makefile
@@ -0,0 +1,28 @@
+# Created by: Christopher Hall <hsw@bitmark.com>
+# $FreeBSD$
+
+PORTNAME= libargon2
+PORTVERSION= 20160530
+CATEGORIES= security devel
+
+MAINTAINER= hsw@bitmark.com
+COMMENT= Memory hard password hashing program and library
+
+LICENSE= CC0-1.0
+
+USE_GITHUB= yes
+GH_ACCOUNT= P-H-C
+GH_PROJECT= phc-winner-argon2
+GH_TAGNAME= 4625cc5
+
+USES= gmake
+USE_LDCONFIG= yes
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/include/argon2.h ${STAGEDIR}${PREFIX}/include
+ ${INSTALL_LIB} ${WRKSRC}/libargon2.a ${STAGEDIR}${PREFIX}/lib
+ ${INSTALL_LIB} ${WRKSRC}/libargon2.so ${STAGEDIR}${PREFIX}/lib
+ ${INSTALL_PROGRAM} ${WRKSRC}/argon2 ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/man/argon2.1 ${STAGEDIR}${PREFIX}/man/man1
+
+.include <bsd.port.mk>