aboutsummaryrefslogtreecommitdiffstats
path: root/security/libargon2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/libargon2/Makefile')
-rw-r--r--security/libargon2/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/security/libargon2/Makefile b/security/libargon2/Makefile
index 378a15cb76d2..81b33a2bd6b4 100644
--- a/security/libargon2/Makefile
+++ b/security/libargon2/Makefile
@@ -2,18 +2,18 @@
# $FreeBSD$
PORTNAME= libargon2
-PORTVERSION= 20160530
+PORTVERSION= 20160821
CATEGORIES= security devel
MAINTAINER= hsw@bitmark.com
COMMENT= Memory hard password hashing program and library
LICENSE= CC0-1.0
+LICENSE_FILE= ${WRKSRC}/LICENSE
USE_GITHUB= yes
GH_ACCOUNT= P-H-C
GH_PROJECT= phc-winner-argon2
-GH_TAGNAME= 4625cc5
USES= gmake
USE_LDCONFIG= yes
@@ -22,7 +22,7 @@ MAKE_JOBS_UNSAFE= yes
do-install:
${INSTALL_DATA} ${WRKSRC}/include/argon2.h ${STAGEDIR}${PREFIX}/include
- ${INSTALL_LIB} ${WRKSRC}/libargon2.a ${STAGEDIR}${PREFIX}/lib
+ ${INSTALL_DATA} ${WRKSRC}/libargon2.a ${STAGEDIR}${PREFIX}/lib
${INSTALL_LIB} ${WRKSRC}/libargon2.so ${STAGEDIR}${PREFIX}/lib
${INSTALL_PROGRAM} ${WRKSRC}/argon2 ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/man/argon2.1 ${STAGEDIR}${PREFIX}/man/man1