aboutsummaryrefslogtreecommitdiffstats
path: root/security/libgcrypt-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/libgcrypt-devel/Makefile')
-rw-r--r--security/libgcrypt-devel/Makefile56
1 files changed, 0 insertions, 56 deletions
diff --git a/security/libgcrypt-devel/Makefile b/security/libgcrypt-devel/Makefile
deleted file mode 100644
index 2cd35ab7d447..000000000000
--- a/security/libgcrypt-devel/Makefile
+++ /dev/null
@@ -1,56 +0,0 @@
-# New ports collection Makefile for: libgcrypt
-# Date created: July 17 2002
-# Whom: Tilman Linneweh <arved@FreeBSD.org>
-#
-# $FreeBSD$
-
-PORTNAME= libgcrypt
-PORTVERSION= 1.1.91
-PORTREVISION= 1
-CATEGORIES= security
-MASTER_SITES= ${MASTER_SITE_GNUPG}
-MASTER_SITE_SUBDIR= alpha/libgcrypt
-DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} \
- ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}.sig
-
-MAINTAINER= arved@FreeBSD.org
-COMMENT= "General purpose crypto library based on code used in GnuPG"
-
-LIB_DEPENDS= gpg-error.1:${PORTSDIR}/security/libgpg-error
-
-CONFLICTS= libgcrypt-1.1*
-USE_REINPLACE= yes
-USE_PERL5= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --with-pth=no
-INSTALLS_SHLIB= yes
-
-INFO= gcrypt
-
-.include <bsd.port.pre.mk>
-
-pre-extract:
-.if exists(${PREFIX}/bin/gpg)
- @${MKDIR} ${WRKDIR}
- @${ECHO_CMD} "===> Verifying GnuPG Signature."
- -${PREFIX}/bin/gpg --no-default-keyring --keyring ${WRKDIR}/keyring \
- --keyserver pgp.mit.edu --recv-key 57548DCD
- cd ${DISTDIR}; ${PREFIX}/bin/gpg --keyring ${WRKDIR}/keyring --verify \
- ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}.sig \
- ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
-.else
- @${ECHO_CMD} "===> GnuPG not installed. Signature can not be verified"
-.endif
-
-post-patch:
- @${FIND} ${WRKSRC} -name "configure" | ${XARGS} ${REINPLACE_CMD} -e \
- 's|-lpthread|${PTHREAD_LIBS}|g'
- @${REINPLACE_CMD} -e s'|-lpthread|${PTHREAD_LIBS}|g' \
- ${WRKSRC}/src/Makefile.in
-
-pre-configure:
- @${RM} -f ${WRKSRC}/doc/gcrypt.info*
-
-.include <bsd.port.post.mk>