aboutsummaryrefslogtreecommitdiffstats
path: root/security/libmcrypt/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/libmcrypt/Makefile')
-rw-r--r--security/libmcrypt/Makefile23
1 files changed, 4 insertions, 19 deletions
diff --git a/security/libmcrypt/Makefile b/security/libmcrypt/Makefile
index 0b40b08d9309..dead627fb22c 100644
--- a/security/libmcrypt/Makefile
+++ b/security/libmcrypt/Makefile
@@ -6,41 +6,26 @@
#
PORTNAME= libmcrypt
-PORTVERSION= 2.5.3
+PORTVERSION= 2.5.4
CATEGORIES= security
MASTER_SITES= ftp://mcrypt.hellug.gr/pub/mcrypt/libmcrypt/ \
ftp://ftp.ntua.gr/pub/security/mcrypt/libmcrypt/
MAINTAINER= ports@FreeBSD.org
-BUILD_DEPENDS= autoconf:${PORTSDIR}/devel/autoconf
-LIB_DEPENDS= ltdl.1:${PORTSDIR}/devel/libtool
-
RESTRICTED= "yes - cryptography"
USE_PERL5= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --enable-static
INSTALLS_SHLIB= yes
MAN3= mcrypt.3
-post-extract:
-# so we need not audit the configure scripts
- ${FIND} ${WRKSRC} -name configure -exec ${RM} -f \{\} \;
-
-pre-patch:
- @${FIND} ${WRKSRC}/modules -name '*.[ch]' | ${XARGS} ${REINPLACE_CMD} -e \
- 's|#ifdef USE_LTDL|#if defined(USE_LTDL) && !defined(__FreeBSD__)|g'
-
post-patch:
- @cd ${WRKSRC}/libltdl && ${LOCALBASE}/bin/autoconf
-
-pre-configure:
-# because we removed the configure scripts
- cd ${WRKSRC} && autoconf
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|: install-pkglibLTLIBRARIES|:|g'
.include <bsd.port.mk>