aboutsummaryrefslogtreecommitdiffstats
path: root/security/libsparkcrypto/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/libsparkcrypto/Makefile')
-rw-r--r--security/libsparkcrypto/Makefile28
1 files changed, 18 insertions, 10 deletions
diff --git a/security/libsparkcrypto/Makefile b/security/libsparkcrypto/Makefile
index 552122baab10..7bcf2f0e6674 100644
--- a/security/libsparkcrypto/Makefile
+++ b/security/libsparkcrypto/Makefile
@@ -3,6 +3,7 @@
PORTNAME= libsparkcrypto
PORTVERSION= 0.1.1
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://senier.net/libsparkcrypto/
EXTRACT_SUFX= .tgz
@@ -12,28 +13,35 @@ COMMENT= Cryptographic library implemented in SPARK
LICENSE= BSD
-USES= ada
-USE_GMAKE= yes
+USES= ada gmake
USE_DOS2UNIX= Makefile build/libsparkcrypto.gpr
SPARKARCH:= ${ARCH:S/amd64/x86_64/:S/i386/i686/}
-
-# The APIDOC requires AdaBrowse which in turn requires ASIS which is
-# coupled with the compiler. There is a question whether Adacore's
-# GPL ASIS is even compatible with FSF GNAT, which is what gcc-aux is.
-# Until this question is answered, skip API document building.
+DESTINY= ${WRKDIR}/destino
MAKE_ENV+= SPARKARCH=${SPARKARCH} \
SPARK_DIR=${WRKSRC}/src/spark \
- DESTDIR=${LOCALBASE} \
+ DESTDIR=${DESTINY} \
MODE=release \
RUNTIME=native \
NO_TESTS=true \
- NO_PROOF=true \
- NO_APIDOC=true
+ NO_PROOF=true
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
+BUILD_DEPENDS+= adabrowse:${PORTSDIR}/textproc/adabrowse
+.else
+MAKE_ENV+= NO_APIDOC=true
+.endif
post-patch:
# ports passed unwanted ARCH definition to Makefile
@${REINPLACE_CMD} -e 's|ARCH|SPARKARCH|g' \
${WRKSRC}/Makefile
+post-install:
+ ${CP} -pR ${DESTINY}${PREFIX}/ ${PREFIX}/
+
.include <bsd.port.mk>