aboutsummaryrefslogtreecommitdiffstats
path: root/security/makepasswd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/makepasswd/Makefile')
-rw-r--r--security/makepasswd/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/security/makepasswd/Makefile b/security/makepasswd/Makefile
new file mode 100644
index 000000000000..2e69dd8962f0
--- /dev/null
+++ b/security/makepasswd/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: makepasswd
+# Date created: 7 March 2003
+# Whom: Toni Viemerö <toni.viemero@iki.fi>
+#
+# $FreeBSD$
+#
+
+PORTNAME= makepasswd
+PORTVERSION= 1.10
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_DEBIAN}
+MASTER_SITE_SUBDIR= dists/potato/main/source/admin/
+DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
+
+MAINTAINER= toni.viemero@iki.fi
+COMMENT= Random password generator
+
+NO_BUILD= yes
+USE_PERL5_RUN= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+MAN1= makepasswd.1
+DOCS= CHANGES README
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/makepasswd ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${PREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>