aboutsummaryrefslogtreecommitdiffstats
path: root/security/mate-keyring/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/mate-keyring/Makefile')
-rw-r--r--security/mate-keyring/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/security/mate-keyring/Makefile b/security/mate-keyring/Makefile
new file mode 100644
index 000000000000..5cb03c7ed988
--- /dev/null
+++ b/security/mate-keyring/Makefile
@@ -0,0 +1,41 @@
+# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= mate-keyring
+PORTVERSION= 1.6.0
+CATEGORIES= security mate
+MASTER_SITES= MATE
+DIST_SUBDIR= mate
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= A program that keeps passwords and other secrets
+
+BUILD_DEPENDS= gtkdoc-check:${PORTSDIR}/textproc/gtk-doc \
+ ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
+LIB_DEPENDS= libdbus-1.so:${PORTSDIR}/devel/dbus \
+ libgcrypt.so:${PORTSDIR}/security/libgcrypt \
+ libtasn1.so:${PORTSDIR}/security/libtasn1
+RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
+
+PORTSCOUT= limitw:1,even
+
+USES= gettext gmake pathfix pkgconfig
+USE_XZ= yes
+USE_MATE= autogen common:build intlhack libmatekeyring ltverhack
+USE_GNOME= gnomehier glib20 gtk20
+USE_LDCONFIG= yes
+USE_AUTOTOOLS= aclocal:env autoconf:env automake:env libtool libtoolize:env
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-pam-dir="${PREFIX}/lib" \
+ --with-root-certs="${LOCALBASE}/share/certs" \
+ --with-gtk=2.0 \
+ --disable-gtk-doc \
+ --with-html-dir=${PREFIX}/share/doc
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+PATHFIX_MAKEFILEIN= Makefile.*
+
+GLIB_SCHEMAS= org.mate.crypto.cache.gschema.xml \
+ org.mate.crypto.pgp.gschema.xml
+
+.include <bsd.port.mk>