aboutsummaryrefslogtreecommitdiffstats
path: root/security/nacl
diff options
context:
space:
mode:
Diffstat (limited to 'security/nacl')
-rw-r--r--security/nacl/Makefile2
-rw-r--r--security/nacl/files/patch-socket_udp.c13
2 files changed, 15 insertions, 0 deletions
diff --git a/security/nacl/Makefile b/security/nacl/Makefile
index eda1b0768b00..243a35dac939 100644
--- a/security/nacl/Makefile
+++ b/security/nacl/Makefile
@@ -26,6 +26,8 @@ HOSTNAME_CMD?= /bin/hostname -s
post-patch:
@${REINPLACE_CMD} -i -e "s/$$/ -fPIC/" ${WRKSRC}/okcompilers/c
+ @${REINPLACE_CMD} -i -e "s/gcc/${CC}/" ${WRKSRC}/okcompilers/c
+ @${REINPLACE_CMD} -i -e "s/c++/${CXX}/" ${WRKSRC}/okcompilers/cpp
pre-build:
${RM} -rf ${WRKSRC}/crypto_onetimeauth/poly1305/amd64
diff --git a/security/nacl/files/patch-socket_udp.c b/security/nacl/files/patch-socket_udp.c
new file mode 100644
index 000000000000..d8869aaf0ff2
--- /dev/null
+++ b/security/nacl/files/patch-socket_udp.c
@@ -0,0 +1,13 @@
+--- curvecp/socket_udp.c.orig 2014-01-29 15:34:07.000000000 -0800
++++ curvecp/socket_udp.c 2014-01-29 15:34:12.000000000 -0800
+@@ -6,6 +6,10 @@
+ #include "socket.h"
+ #include "blocking.h"
+
++#ifndef SOL_IP
++#define SOL_IP IPPROTO_IP /* FreeBSD requires protocol number */
++#endif
++
+ static void enable_bsd_fragmentation(int fd)
+ {
+ #ifdef IP_DONTFRAG
reebsd-ports-gnome/commit/www/drood?h=dependabot/npm_and_yarn/devel/electron6/files/ini-1.3.8&id=85faa678bd8e52cc81bdbc24758ccecb87b5ae10'>- Fix distinfotabthorpe2013-10-251-2/+2 * - Update to 3.10tabthorpe2013-10-252-3/+3 * - Update to 3.9tabthorpe2013-10-182-3/+3 * - Update to 3.8tabthorpe2013-10-094-14/+4 * Add NO_STAGE all over the place in preparation for the staging support (cat: ...bapt2013-09-211-0/+1 * - Update 3.6tabthorpe2013-09-102-3/+3 * - Update to 3.5tabthorpe2013-09-042-9/+4 * - Author re-rolled tarballtabthorpe2012-09-082-2/+3 * - Update to 3.4jase2012-09-05