aboutsummaryrefslogtreecommitdiffstats
path: root/security/openssh-portable/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/openssh-portable/Makefile')
-rw-r--r--security/openssh-portable/Makefile26
1 files changed, 23 insertions, 3 deletions
diff --git a/security/openssh-portable/Makefile b/security/openssh-portable/Makefile
index ff013ce24442..0a642dd70d07 100644
--- a/security/openssh-portable/Makefile
+++ b/security/openssh-portable/Makefile
@@ -6,16 +6,33 @@
#
PORTNAME= openssh
-PORTVERSION= 3.8.1p1
+PORTVERSION= 3.9.0.1
+.if defined(OPENSSH_SNAPSHOT)
+PORTREVISION!= date -v-1d +%Y%m%d
+.endif
PORTEPOCH= 1
CATEGORIES= security ipv6
-MASTER_SITES= ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/ \
- ftp://carroll.cac.psu.edu/pub/OpenBSD/OpenSSH/portable/
+MASTER_SITES= ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/%SUBDIR%/ \
+ ftp://carroll.cac.psu.edu/pub/OpenBSD/OpenSSH/portable/%SUBDIR%/
PKGNAMESUFFIX?= ${PORTABLE_SUFFIX}${GSSAPI_SUFFIX}${BASE_SUFFIX}${PKGNAMESUFFIX2}
+MASTER_SITE_SUBDIR= ${MASTER_SITE_SUBDIR2}
+DISTNAME= ${DISTNAME2}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= The portable version of OpenBSD's OpenSSH
+OPENSSHVERSION= 3.9p1
+.if defined(OPENSSH_SNAPSHOT)
+MASTER_SITE_SUBDIR2= snapshot/
+DISTNAME2= ${PORTNAME}-SNAP-${PORTREVISION}
+NO_CHECKSUM= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+.else
+MASTER_SITE_SUBDIR2=
+DISTNAME2= ${PORTNAME}-${OPENSSHVERSION}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${OPENSSHVERSION}
+.endif
+
MAN1= sftp.1 ssh-add.1 ssh-agent.1 ssh-keygen.1 ssh-keyscan.1 scp.1 ssh.1
MLINKS= ssh.1 slogin.1
MAN5= ssh_config.5 sshd_config.5
@@ -130,6 +147,9 @@ test:
.include <bsd.port.pre.mk>
+SUDO?=
+MAKE_ENV+= SUDO="${SUDO}"
+
.if defined(KRB5_HOME) && exists(${KRB5_HOME}) || defined(WITH_GSSAPI)
.if ${OPENSSLBASE} == "/usr"
CONFIGURE_ARGS+= --without-rpath
td>-3/+3 * - Chase devel/sdl12 shlib version bumpmiwi2008-03-131-1/+1 * Use system compiler on CURRENTarved2007-06-011-1/+1 * - Welcome X.org 7.2 \o/.flz2007-05-202-9/+2 * - Update to 0.5.6miwi2007-04-213-4/+5 * - Remove FreeBSD 4.X support from unmaintained ports in categories startinggabor2007-04-161-7/+1 * - Remove duplicate USE_XLIB entrymiwi2006-12-041-1/+0 * - Update to 0.5.5miwi2006-12-043-6/+6 * Back out CONFIGURE_ARGS change, it is already handled by USE_XLIB and GNU_CON...laszlof2006-12-021-2/+0 * Respect X11BASE and USE_XLIBlaszlof2006-12-021-0/+3 * - Update devel/sdl12 to version 1.2.11. Now we employ stock SDL directorystas2006-09-201-0/+1 * Add missing locale files to plist.shaun2006-08-08etions'>-1/+1 * SIZEify.kuriyama2004-03-181-0/+2 * Add USE_GETTEXT and bump PORTREVISION.marcus2004-02-041-2/+2