aboutsummaryrefslogtreecommitdiffstats
path: root/security/openssh
diff options
context:
space:
mode:
Diffstat (limited to 'security/openssh')
-rw-r--r--security/openssh/Makefile1
-rw-r--r--security/openssh/files/patch-channels.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/security/openssh/Makefile b/security/openssh/Makefile
index 81612a839eaf..a62d8071483c 100644
--- a/security/openssh/Makefile
+++ b/security/openssh/Makefile
@@ -7,6 +7,7 @@
PORTNAME= openssh
PORTVERSION= 3.0.2
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/ \
ftp://ftp.usa.openbsd.org/pub/OpenBSD/OpenSSH/ \
diff --git a/security/openssh/files/patch-channels.c b/security/openssh/files/patch-channels.c
new file mode 100644
index 000000000000..fc11fc9c6bad
--- /dev/null
+++ b/security/openssh/files/patch-channels.c
@@ -0,0 +1,11 @@
+--- channels.c.orig Wed Oct 10 17:18:47 2001
++++ channels.c Wed Mar 6 07:49:46 2002
+@@ -145,7 +145,7 @@
+ {
+ Channel *c;
+
+- if (id < 0 || id > channels_alloc) {
++ if (id < 0 || id >= channels_alloc) {
+ log("channel_lookup: %d: bad id", id);
+ return NULL;
+ }