aboutsummaryrefslogtreecommitdiffstats
path: root/security/openssl-beta/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/openssl-beta/Makefile')
-rw-r--r--security/openssl-beta/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/security/openssl-beta/Makefile b/security/openssl-beta/Makefile
index e15c2df6a90c..3abdf091cde9 100644
--- a/security/openssl-beta/Makefile
+++ b/security/openssl-beta/Makefile
@@ -7,6 +7,7 @@
PORTNAME= openssl
PORTVERSION= 0.9.7
+PORTREVISION= 1
CATEGORIES= security devel
MASTER_SITES= http://www.openssl.org/source/ \
ftp://ftp.openssl.org/source/ \
@@ -34,7 +35,11 @@ PLIST_SUB+= SHARED="@comment "
.else
PLIST_SUB+= SHARED=""
ALL_TARGET= freebsd-shared all
+.if exists(/usr/lib/libcrypto.so.3)
+SHLIBVER= 4
+.else
SHLIBVER= 3
+.endif
MAKE_ENV+= SHLIBVER=${SHLIBVER}
PLIST_SUB+= SHLIBVER=${SHLIBVER}
INSTALLS_SHLIB= yes