aboutsummaryrefslogtreecommitdiffstats
path: root/security/openssl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/openssl/Makefile')
-rw-r--r--security/openssl/Makefile21
1 files changed, 8 insertions, 13 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index 7a500e1ba26e..18535153c88e 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -1,27 +1,22 @@
# New ports collection makefile for: OpenSSL
-# Version required: 0.9.2b
+# Version required: 0.9.3
# Date created: Sun Jan 3 19:36:27 CET 1999
# Whom: Dirk Froemberg <dirk@FreeBSD.ORG>
#
-# $Id: Makefile,v 1.29 1999/04/13 22:37:02 dirk Exp $
+# $Id: Makefile,v 1.30 1999/04/22 00:17:15 scrappy Exp $
#
-DISTNAME= openssl-0.9.2b
+DISTNAME= openssl-0.9.3
CATEGORIES= devel security
MASTER_SITES= http://www.openssl.org/source/ \
ftp://ftp.openssl.org/source/ \
ftp://ftp.sunet.se/pub/security/tools/net/openssl/source/ \
ftp://ftp.cert.dfn.de/pub/tools/net/openssl/source/
-PATCH_SITES= ${MASTER_SITES}
-PATCHFILES= openssl-0.9.2b-rsaoaep.patch
-
MAINTAINER= dirk@FreeBSD.ORG
-ONLY_FOR_ARCHS= i386
RESTRICTED= "Cryptography"
USE_PERL5= yes
-MAKE_ENV= PERL="${PERL}"
.if !defined(USA_RESIDENT) || ${USA_RESIDENT} != YES && ${USA_RESIDENT} != NO
pre-fetch:
@@ -33,21 +28,21 @@ pre-fetch:
.elif defined(USA_RESIDENT)
.if ${USA_RESIDENT} == YES && !defined(I_HAVE_AN_RSA_LICENSE)
LIB_DEPENDS= rsaref.2:${PORTSDIR}/security/rsaref
-
-post-configure:
- ${PATCH} ${PATCH_ARGS} < ${FILESDIR}/Makefile.patch
+RSAREF= rsaref
.endif
.endif
do-configure:
@cd ${WRKSRC} \
- && ${SETENV} CC="${CC}" CFLAGS="${CFLAGS}" PERL="${PERL}" ./config \
- && ${PERL} util/ssldir.pl ${PREFIX}
+ && ${SETENV} CC="${CC}" CFLAGS="${CFLAGS}" PERL="${PERL}" \
+ ./config --prefix=${PREFIX} --openssldir=${PREFIX}/openssl \
+ ${RSAREF} -L${PREFIX}/lib
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/openssl
@${INSTALL_DATA} ${WRKSRC}/doc/* ${PREFIX}/share/doc/openssl
.endif
+ @${CAT} ${PKGDIR}/MESSAGE
.include <bsd.port.mk>