aboutsummaryrefslogtreecommitdiffstats
path: root/security/openssl
diff options
context:
space:
mode:
Diffstat (limited to 'security/openssl')
-rw-r--r--security/openssl/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index 7523ae8d5095..040740560401 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -855,7 +855,11 @@ MLINKS= dgst.1 md4.1 \
OPENSSL_BASE_SONAME!= readlink ${DESTDIR}/usr/lib/libcrypto.so || true
OPENSSL_SHLIBVER_BASE= ${OPENSSL_BASE_SONAME:E}
OPENSSL_BASE_SOPATH= ${OPENSSL_BASE_SONAME:H}
+.if ( ${OSVERSION} >= 800105 )
+OPENSSL_SHLIBVER?= 6
+.else
OPENSSL_SHLIBVER?= 5
+.endif
.if !defined(WITHOUT_SSE2)
# disable runtime SSE2 detection