aboutsummaryrefslogtreecommitdiffstats
path: root/security/ossec-hids-server/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/ossec-hids-server/Makefile')
-rw-r--r--security/ossec-hids-server/Makefile24
1 files changed, 21 insertions, 3 deletions
diff --git a/security/ossec-hids-server/Makefile b/security/ossec-hids-server/Makefile
index 2a7019fd491e..8dfe96dfd453 100644
--- a/security/ossec-hids-server/Makefile
+++ b/security/ossec-hids-server/Makefile
@@ -6,18 +6,24 @@
#
PORTNAME= ossec-hids
-PORTVERSION= 1.3
+PORTVERSION= 1.4
PORTREVISION?= 0
CATEGORIES= security
MASTER_SITES= http://www.ossec.net/files/ \
http://www.ossec.net/files/old/
-PKGNAMESUFFIX?= -server
+PKGNAMESUFFIX= -server
MAINTAINER= valerio.daelli@gmail.com
-COMMENT= A security tool to monitor and check logs and intrusions
+COMMENT?= A security tool to monitor and check logs and intrusions
USE_RC_SUBR= ossec-hids
+.if defined(WITH_DB)
+USE_MYSQL= yes
+USE_PGSQL= yes
+USE_BDB= yes
+.endif
+
SUB_LIST= PORTNAME=${PORTNAME}
SUB_FILES= pkg-message
PLIST_SUB= PORTNAME=${PORTNAME}
@@ -40,7 +46,19 @@ post-patch:
@${REINPLACE_CMD} 's|PREFIX|${PREFIX}/${PORTNAME}|' ${WRKSRC}/src/headers/defs.h
do-build:
+.if defined(WITH_DB)
+.if defined(CLIENT_ONLY)
+ @cd ${WRKSRC}/src;${MAKE} setagent;${MAKE} all;${MAKE} build
+.else
+ @cd ${WRKSRC}/src;${MAKE} setdb;${MAKE} all;${MAKE} build
+.endif
+.else
+.if defined(CLIENT_ONLY)
+ @cd ${WRKSRC}/src;${MAKE} setagent;${MAKE} all;${MAKE} build
+.else
@cd ${WRKSRC}/src;${MAKE} all;${MAKE} build
+.endif
+.endif
.if defined(CLIENT_ONLY)
do-install: