aboutsummaryrefslogtreecommitdiffstats
path: root/security/p5-Authen-PAAS/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/p5-Authen-PAAS/Makefile')
-rw-r--r--security/p5-Authen-PAAS/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/security/p5-Authen-PAAS/Makefile b/security/p5-Authen-PAAS/Makefile
new file mode 100644
index 000000000000..ded5ea0b2a33
--- /dev/null
+++ b/security/p5-Authen-PAAS/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: p5-Authen-PAAS
+# Date created: 22 Jun 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Authen-PAAS
+PORTVERSION= 1.1.1
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Authen
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Perl Authentication & Authorization Service
+
+BUILD_DEPENDS= p5-Config-Record>=1.1.0:${PORTSDIR}/devel/p5-Config-Record \
+ p5-Log-Log4perl>0:${PORTSDIR}/devel/p5-Log-Log4perl
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN1= authen-paas-passwd.1
+MAN3= Authen::PAAS.3 \
+ Authen::PAAS::BasicLoginModule.3 \
+ Authen::PAAS::BasicUser.3 \
+ Authen::PAAS::Callback.3 \
+ Authen::PAAS::ConsoleCallback.3 \
+ Authen::PAAS::Context.3 \
+ Authen::PAAS::Credential.3 \
+ Authen::PAAS::LoginModule.3 \
+ Authen::PAAS::Principal.3 \
+ Authen::PAAS::SimpleCallback.3 \
+ Authen::PAAS::Subject.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600 # inherited from p5-Config-Record
+IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
span class='deletions'>-1/+1 * Bump PORTREVISION for ports depending on the canonical version of GCCgerald2017-09-111-1/+1 * Explicitly build with -std=gnu++03.rakuco2017-08-011-0/+4 * devel/boost-*: update to 1.64.0jbeich2017-05-021-1/+1 * Bump PORTREVISIONs for ports depending on the canonical version of GCC andgerald2017-04-011-1/+1 * Remove all _USE=openssl occurrences.mat2017-03-151-1/+1 * Update WWW: SF redirects to https://sourceforge.net/projects/<PROJECT_NAME>/sunpoet2017-01-211-1/+1 * devel/boost-*: update to 1.63.0jbeich2017-01-06