aboutsummaryrefslogtreecommitdiffstats
path: root/security/p5-Crypt-Random-Seed/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/p5-Crypt-Random-Seed/Makefile')
-rw-r--r--security/p5-Crypt-Random-Seed/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/security/p5-Crypt-Random-Seed/Makefile b/security/p5-Crypt-Random-Seed/Makefile
new file mode 100644
index 000000000000..ca50d524f32d
--- /dev/null
+++ b/security/p5-Crypt-Random-Seed/Makefile
@@ -0,0 +1,24 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Crypt-Random-Seed
+PORTVERSION= 0.03
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Simple method to get strong randomness
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= p5-Crypt-Random-TESHA2>=0:${PORTSDIR}/security/p5-Crypt-Random-TESHA2
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+NO_ARCH= yes
+USE_PERL5= configure
+USES= perl5
+
+.include <bsd.port.mk>