aboutsummaryrefslogtreecommitdiffstats
path: root/security/p5-Crypt-SKey/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/p5-Crypt-SKey/Makefile')
-rw-r--r--security/p5-Crypt-SKey/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/security/p5-Crypt-SKey/Makefile b/security/p5-Crypt-SKey/Makefile
index 6200b4b26a90..4a878975c32a 100644
--- a/security/p5-Crypt-SKey/Makefile
+++ b/security/p5-Crypt-SKey/Makefile
@@ -5,6 +5,7 @@
PORTNAME= Crypt-SKey
PORTVERSION= 0.07
+PORTREVISION= 1
CATEGORIES= security perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Crypt
@@ -13,12 +14,13 @@ PKGNAMEPREFIX= p5-
MAINTAINER= gkovesdan@t-hosting.hu
COMMENT= Perl S/Key calculator
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD4.pm:${PORTSDIR}/security/p5-Digest-MD4 \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${SITE_PERL}/${PERL_ARCH}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
PERL_CONFIGURE= yes
MAN3= Crypt::SKey.3
-.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} <= 500503
-IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>