aboutsummaryrefslogtreecommitdiffstats
path: root/security/p5-Digest-DJB/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/p5-Digest-DJB/Makefile')
-rw-r--r--security/p5-Digest-DJB/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/security/p5-Digest-DJB/Makefile b/security/p5-Digest-DJB/Makefile
new file mode 100644
index 000000000000..6fbd06e28464
--- /dev/null
+++ b/security/p5-Digest-DJB/Makefile
@@ -0,0 +1,24 @@
+# Ports collection Makefile for: p5-Digest-DJB
+# Date created: 17 Dec 2005
+# Whom: Gabor Kovesdan
+# $FreeBSD$
+
+PORTNAME= Digest-DJB
+PORTVERSION= 1.00
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Digest
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gkovesdan@t-hosting.hu
+COMMENT= Perl extension for D.J Bernstein's hash algorithm
+
+PERL_CONFIGURE= yes
+
+MAN3= Digest::DJB.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500503
+IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>