aboutsummaryrefslogtreecommitdiffstats
path: root/security/p5-GD-SecurityImage/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/p5-GD-SecurityImage/Makefile')
-rw-r--r--security/p5-GD-SecurityImage/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/security/p5-GD-SecurityImage/Makefile b/security/p5-GD-SecurityImage/Makefile
index b81e9e1e80b3..4b32798b22cb 100644
--- a/security/p5-GD-SecurityImage/Makefile
+++ b/security/p5-GD-SecurityImage/Makefile
@@ -18,7 +18,8 @@ COMMENT= Perl5 module for creating CAPTCHA security images
BUILD_DEPENDS= p5-GD>=0:${PORTSDIR}/graphics/p5-GD
RUN_DEPENDS= p5-GD>=0:${PORTSDIR}/graphics/p5-GD
-OPTIONS= IMAGEMAGICK "Build ImageMagick module" off
+OPTIONS_DEFINE= IMAGEMAGICK
+IMAGEMAGICK_DESC= Build ImageMagick module
PORTSCOUT= skipv:1.581
@@ -31,7 +32,7 @@ MAN3= GD::SecurityImage.3 \
.include <bsd.port.options.mk>
-.if defined(WITH_IMAGEMAGICK)
+.if ${PORT_OPTIONS:MIMAGEMAGICK}
BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Image/Magick.pm:${PORTSDIR}/graphics/ImageMagick
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Image/Magick.pm:${PORTSDIR}/graphics/ImageMagick
.endif