aboutsummaryrefslogtreecommitdiffstats
path: root/security/pecl-gnupg/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/pecl-gnupg/Makefile')
-rw-r--r--security/pecl-gnupg/Makefile19
1 files changed, 2 insertions, 17 deletions
diff --git a/security/pecl-gnupg/Makefile b/security/pecl-gnupg/Makefile
index 6cdcaa653487..2e73a9f0400c 100644
--- a/security/pecl-gnupg/Makefile
+++ b/security/pecl-gnupg/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gnupg
-PORTVERSION= 1.2
-PORTREVISION= 1
+PORTVERSION= 1.3
CATEGORIES= security
MASTER_SITES= http://pecl.php.net/get/
PKGNAMEPREFIX= pecl-
@@ -27,15 +26,6 @@ CONFIGURE_ARGS= --with-gnupg=${LOCALBASE}/include/gpgme
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
-EXAMPLESDIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
-
-PLIST_FILES= %%EXAMPLESDIR%%/clearsign.php %%EXAMPLESDIR%%/decrypt.php \
- %%EXAMPLESDIR%%/encrypt.php %%EXAMPLESDIR%%/encryptsign.php \
- %%EXAMPLESDIR%%/export.php %%EXAMPLESDIR%%/import.php \
- %%EXAMPLESDIR%%/keyinfo.php %%EXAMPLESDIR%%/main.php \
- %%EXAMPLESDIR%%/verify.php
-PLIST_DIRS= %%EXAMPLESDIR%%
-
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000 && ${PHP_VER} == 5
@@ -43,12 +33,7 @@ USE_GCC= 3.2+
.endif
post-patch:
- @${REINPLACE_CMD} -e "s|\$$GNUPG_DIR/include|${LOCALBASE}/include/gpgme|" \
- -e "s|\$$GNUPG_DIR/lib|${LOCALBASE}/lib|" -e "s|-ldl||g" \
+ @${REINPLACE_CMD} -e "s|\$$GNUPG_DIR/lib|${LOCALBASE}/lib|" -e "s|-ldl||g" \
${WRKSRC}/config.m4
-post-install:
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/examples/*.php ${EXAMPLESDIR}
-
.include <bsd.port.post.mk>