aboutsummaryrefslogtreecommitdiffstats
path: root/security/prelude-lml/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/prelude-lml/Makefile')
-rw-r--r--security/prelude-lml/Makefile25
1 files changed, 22 insertions, 3 deletions
diff --git a/security/prelude-lml/Makefile b/security/prelude-lml/Makefile
index 766b61c739b4..de7b1288e7cc 100644
--- a/security/prelude-lml/Makefile
+++ b/security/prelude-lml/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= prelude-lml
-PORTVERSION= 0.9.7
+PORTVERSION= 0.9.8.1
CATEGORIES= security
MASTER_SITES= http://www.prelude-ids.org/download/releases/ \
http://www.prelude-ids.org/download/releases/old/
@@ -13,7 +13,7 @@ MASTER_SITES= http://www.prelude-ids.org/download/releases/ \
MAINTAINER= r.gruyters@yirdis.nl
COMMENT= Prelude Network Intrusion Detection System Log Monitoring Lackey
-LIB_DEPENDS+= prelude.10:${PORTSDIR}/security/libprelude \
+LIB_DEPENDS+= prelude.11:${PORTSDIR}/security/libprelude \
pcre.0:${PORTSDIR}/devel/pcre
USE_GPG= yes
@@ -24,4 +24,23 @@ USE_RC_SUBR= prelude-lml.sh
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS+= --with-html-dir=${PREFIX}/share/doc
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_FAM)
+USE_FAM= yes
+CONFIGURE_ARGS+= --enable-fam
+.else
+CONFIGURE_ARGS+= --disable-fam
+.endif
+
+post-install:
+ @if [ -f ${PREFIX}/etc/prelude-lml/prelude-lml.conf ]; then \
+ ${CP} -p ${PREFIX}/etc/prelude-lml/prelude-lml.conf-dist \
+ ${PREFIX}/etc/prelude-lml/prelude-lml.conf ; \
+ fi
+ @if [ -f ${PREFIX}/etc/prelude-lml/plugins.rules ]; then \
+ ${CP} -p ${PREFIX}/etc/prelude-lml/plugins.rules-dist \
+ ${PREFIX}/etc/prelude-lml/plugins.rules ; \
+ fi
+
+.include <bsd.port.post.mk>