aboutsummaryrefslogtreecommitdiffstats
path: root/security/py-m2crypto/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/py-m2crypto/Makefile')
-rw-r--r--security/py-m2crypto/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/security/py-m2crypto/Makefile b/security/py-m2crypto/Makefile
index 6ea55f140bd8..c6e982efce9a 100644
--- a/security/py-m2crypto/Makefile
+++ b/security/py-m2crypto/Makefile
@@ -23,9 +23,13 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/SWIG
USE_PYTHON= yes
USE_ZIP= yes
USE_OPENSSL= yes
+USE_REINPLACE= yes
PINSTALL_PLIST= ${WRKDIR}/pinstall-plist
+post-patch:
+ ${REINPLACE_CMD} "s/PYTHON_VERSION/${PYTHON_VERSION}/" ${WRKSRC}/Makefile
+
post-build:
${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}/../M2Crypto