aboutsummaryrefslogtreecommitdiffstats
path: root/security/py-paramiko/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/py-paramiko/Makefile')
-rw-r--r--security/py-paramiko/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/security/py-paramiko/Makefile b/security/py-paramiko/Makefile
index ae72679e1ea0..ca8920cea910 100644
--- a/security/py-paramiko/Makefile
+++ b/security/py-paramiko/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= paramiko
-PORTVERSION= 1.7.6
+PORTVERSION= 1.7.7.1
CATEGORIES= security python
-MASTER_SITES= http://www.lag.net/paramiko/download/
+MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= sbz@FreeBSD.org
@@ -16,6 +16,9 @@ COMMENT= A python library for making SSH2 connections
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/Crypto/__init__.py:${PORTSDIR}/security/py-pycrypto
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
USE_PYTHON= yes
USE_PYDISTUTILS= yes
@@ -24,7 +27,10 @@ EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
.if !defined(NOPORTEXAMPLES)
post-install:
${MKDIR} ${EXAMPLESDIR}
- ${CP} ${WRKSRC}/demos/* ${EXAMPLESDIR}
+ @(cd ${WRKSRC}/demos && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
.endif
+regression-test:
+ @(cd ${WRKSRC} && ${PYTHON_CMD} test.py)
+
.include <bsd.port.mk>