aboutsummaryrefslogtreecommitdiffstats
path: root/security/sancp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/sancp/Makefile')
-rw-r--r--security/sancp/Makefile39
1 files changed, 16 insertions, 23 deletions
diff --git a/security/sancp/Makefile b/security/sancp/Makefile
index da348f358132..5b16e9cf91bd 100644
--- a/security/sancp/Makefile
+++ b/security/sancp/Makefile
@@ -7,41 +7,34 @@
PORTNAME= sancp
PORTVERSION= 1.6.1
-PORTREVISION= 1
+DISTVERSIONSUFFIX= -stable
+PORTREVISION= 2
CATEGORIES= security
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= sancp
-
-PATCH_SITES= http://sancp.sourceforge.net/
-PATCHFILES= sancp-1.6.1.fix200511.a.patch \
- sancp-1.6.1.fix200606.bd.patch \
- sancp-1.6.1.fix200601.c.patch
-PATCH_DIST_STRIP=-p1
+MASTER_SITES= SF
MAINTAINER= pauls@utdallas.edu
COMMENT= A network connection profiler
-ALL_TARGET= final
+ALL_TARGET= bsd
USE_RC_SUBR= sancp.sh
SUB_FILES= pkg-message
-PORTDOCS= CHANGES INSTALL ISSUES README SETUP fields.LIST
+PORTDOCS= CHANGES INSTALL ISSUES README \
+ SETUP fields.LIST LICENSE
+
+post-extract:
+ @cd ${WRKSRC} && ${MV} LICENSE docs/
-.include <bsd.port.pre.mk>
+do-install:
+ @${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ @${INSTALL_PROGRAM} ${WRKSRC}/sancp ${PREFIX}/bin
+ @${INSTALL_DATA} ${WRKSRC}/etc/sancp/sancp.conf ${PREFIX}/etc/sancp.conf-dist
+ @${CP} -n ${PREFIX}/etc/sancp.conf-dist ${PREFIX}/etc/sancp.conf
-post-install:
- ${SH} ${PKGINSTALL}
- ${INSTALL_PROGRAM} ${WRKSRC}/sancp ${PREFIX}/bin
-.for f in sancp.conf
- ${INSTALL_DATA} ${WRKSRC}/etc/sancp/${f} ${PREFIX}/etc/${f}-dist
- [ -f ${PREFIX}/etc/${f} ] || \
- ${INSTALL_DATA} ${WRKSRC}/etc/sancp/${f} ${PREFIX}/etc/${f}
-.endfor
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} LICENSE ${DOCSDIR}
+ @${INSTALL} -d ${DOCSDIR}/
cd ${WRKSRC}/docs/ && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>