aboutsummaryrefslogtreecommitdiffstats
path: root/security/snort/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/snort/Makefile')
-rw-r--r--security/snort/Makefile25
1 files changed, 13 insertions, 12 deletions
diff --git a/security/snort/Makefile b/security/snort/Makefile
index 08be8a45ef11..6b137b5645b4 100644
--- a/security/snort/Makefile
+++ b/security/snort/Makefile
@@ -7,6 +7,7 @@
PORTNAME= snort
PORTVERSION= 2.8.4.1
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://www.snort.org/dl/ \
http://dl.snort.org/snort-current/
@@ -25,8 +26,8 @@ OPTIONS= DYNAMIC "Enable dynamic plugin support" on \
ODBC "Enable ODBC support" off \
POSTGRESQL "Enable PostgreSQL support" off \
PRELUDE "Enable Prelude NIDS integration" off \
- PERPROFILE "Enable Performance Profiling" off
-# SNORTSAM "Enable output plugin to SnortSam" on
+ PERPROFILE "Enable Performance Profiling" off \
+ SNORTSAM "Enable output plugin to SnortSam" off
USE_RC_SUBR= snort.sh
SUB_FILES= pkg-message
@@ -123,23 +124,23 @@ PLIST_SUB+= PRELUDE="@comment "
CONFIGURE_ARGS+= --enable-perfprofiling
.endif
-#.if defined(WITH_SNORTSAM)
-#PATCH_SITES+=http://www.freebsdbrasil.com.br/~urisso/files/snort/:snortsam
-#PATCHFILES+=snortsam-2.8.2.1.diff:snortsam
-#.endif
+.if defined(WITH_SNORTSAM)
+PATCH_SITES+=http://www.freebsdbrasil.com.br/~urisso/files/snort/:snortsam
+PATCHFILES+=snortsam-2.8.4.1.diff:snortsam
+.endif
post-patch:
-#.if defined(WITH_SNORTSAM)
-#BUILD_DEPENDS+= automake>=1.10.1:${PORTSDIR}/devel/automake110
-#.endif
+.if defined(WITH_SNORTSAM)
+BUILD_DEPENDS+= automake>=1.10.1:${PORTSDIR}/devel/automake110
+.endif
.if defined(NOPORTDOCS)
@${REINPLACE_CMD} '/SUBDIRS = /s/doc//' ${WRKSRC}/Makefile.in
.endif
pre-configure:
-#.if defined(WITH_SNORTSAM)
-# @cd ${WRKSRC} && ${SH} ${WRKSRC}/autojunk.sh
-#.endif
+.if defined(WITH_SNORTSAM)
+ @cd ${WRKSRC} && ${SH} ${WRKSRC}/autojunk.sh
+.endif
${FIND} ${WRKSRC} -name 'Makefile.in' | ${XARGS} ${REINPLACE_CMD} -e \
's|lib/snort_|lib/snort/|g'
${REINPLACE_CMD} "s,/etc/snort.conf,${CONFIG_DIR}/snort.conf," \