aboutsummaryrefslogtreecommitdiffstats
path: root/security/ssh2
diff options
context:
space:
mode:
Diffstat (limited to 'security/ssh2')
-rw-r--r--security/ssh2/Makefile18
-rw-r--r--security/ssh2/distinfo2
-rw-r--r--security/ssh2/pkg-plist12
3 files changed, 13 insertions, 19 deletions
diff --git a/security/ssh2/Makefile b/security/ssh2/Makefile
index 6f8ccfa03aea..ea13d0b706c9 100644
--- a/security/ssh2/Makefile
+++ b/security/ssh2/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ssh2
-PORTVERSION= 3.2.2
+PORTVERSION= 3.2.3
CATEGORIES= security ipv6
MASTER_SITES= ftp://ftp.ssh.com/pub/ssh/ \
ftp://sunsite.unc.edu/pub/packages/security/ssh/ \
@@ -69,9 +69,9 @@ PLIST_SUB= WITH_X11:="@comment "
.endif
MAN1= ssh2.1 ssh-keygen2.1 ssh-add2.1 ssh-agent2.1 scp2.1 sftp2.1 \
- sshregex.1 ssh-probe2.1 ssh-dummy-shell.1 ssh-pubkeymgr.1 \
- ssh-chrootmgr.1
-MAN5= ssh2_config.5 sshd-check-conf.5 sshd2_config.5
+ sshregex.1 ssh-probe2.1 ssh-dummy-shell.1
+MAN5= ssh2_config.5 sshd-check-conf.5 sshd2_config.5 \
+ sshd2_subconfig.5
MAN8= sshd2.8
MLINKS= ssh2.1 ssh.1 ssh-add2.1 ssh-add.1 ssh-agent2.1 ssh-agent.1 \
ssh-keygen2.1 ssh-keygen.1 scp2.1 scp.1 sftp2.1 sftp.1 \
@@ -81,7 +81,7 @@ MANCOMPRESSED= no
PORTDOCS= CHANGES FAQ INSTALL LICENSE MANIFEST NEWS README \
REGEX-SYNTAX SSH2.QUICKSTART
-post-install: install-config-files
+post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
.for i in ${PORTDOCS}
@@ -101,12 +101,4 @@ post-install: install-config-files
fi; \
fi
-install-config-files:
-.for file in ${CONFIG_FILES}
- ${INSTALL_DATA} ${WRKSRC}/apps/ssh/${file} ${SSH2_ETC}/${file}.sample
-.if !exists(${SSH2_ETC}/${file})
- ${INSTALL_DATA} ${WRKSRC}/apps/ssh/${file} ${SSH2_ETC}
-.endif
-.endfor
-
.include <bsd.port.post.mk>
diff --git a/security/ssh2/distinfo b/security/ssh2/distinfo
index 701f71d82094..c383355ab278 100644
--- a/security/ssh2/distinfo
+++ b/security/ssh2/distinfo
@@ -1 +1 @@
-MD5 (ssh-3.2.2.tar.gz) = 5ba56fa6f0d533acf0a83f5d2f0fed43
+MD5 (ssh-3.2.3.tar.gz) = d74afd27a5df00ae8fbbe066ec82c88a
diff --git a/security/ssh2/pkg-plist b/security/ssh2/pkg-plist
index 16eed4f15427..93342b159841 100644
--- a/security/ssh2/pkg-plist
+++ b/security/ssh2/pkg-plist
@@ -9,12 +9,10 @@ bin/ssh-signer2
bin/ssh-probe2
bin/sftp-server2
bin/ssh-dummy-shell
-bin/ssh-pubkeymgr
-bin/ssh-chrootmgr
bin/ssh
bin/ssh-agent
bin/ssh-add
-bin/ssh-askpass
+%%WITH_X11:%%bin/ssh-askpass
bin/ssh-keygen
bin/scp
bin/sftp
@@ -22,9 +20,13 @@ bin/sftp-server
bin/ssh-signer
bin/ssh-probe
etc/rc.d/sshd.sh
-etc/ssh2/sshd2_config.sample
-etc/ssh2/ssh2_config.sample
+etc/ssh2/sshd2_config.example
+etc/ssh2/ssh2_config.example
etc/ssh2/ssh_dummy_shell.out
+etc/ssh2/subconfig/anonymous.example
+etc/ssh2/subconfig/host_ext.example
+etc/ssh2/subconfig/host_int.example
+etc/ssh2/subconfig/user.example
sbin/sshd2
sbin/sshd-check-conf
sbin/sshd