aboutsummaryrefslogtreecommitdiffstats
path: root/security/sudo
diff options
context:
space:
mode:
Diffstat (limited to 'security/sudo')
-rw-r--r--security/sudo/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/security/sudo/Makefile b/security/sudo/Makefile
index 6060e3741426..6c98bab21744 100644
--- a/security/sudo/Makefile
+++ b/security/sudo/Makefile
@@ -37,10 +37,16 @@ CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
OPTIONS= LDAP "With LDAP support" off \
OPIE "With OPIE support" off \
+ INSULTS "With all insults" off \
SHELL_SETS_HOME "Set HOME env to target user in shell mode" off
.include <bsd.port.pre.mk>
+.if defined(WITH_INSULTS)
+CONFIGURE_ARGS+=--with-insults
+CONFIGURE_ARGS+=--with-all-insults
+.endif
+
.if defined(WITH_LDAP)
USE_OPENLDAP=yes
CONFIGURE_ARGS+=--with-ldap=${PREFIX}