aboutsummaryrefslogtreecommitdiffstats
path: root/security/vinetto
diff options
context:
space:
mode:
Diffstat (limited to 'security/vinetto')
-rw-r--r--security/vinetto/Makefile34
-rw-r--r--security/vinetto/distinfo3
-rw-r--r--security/vinetto/pkg-descr16
-rw-r--r--security/vinetto/pkg-plist12
4 files changed, 65 insertions, 0 deletions
diff --git a/security/vinetto/Makefile b/security/vinetto/Makefile
new file mode 100644
index 000000000000..916c3ab56384
--- /dev/null
+++ b/security/vinetto/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: vinetto
+# Date created: 2006-12-26
+# Whom: Aleksander Fafula <alex@BSDGuru.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= vinetto
+PORTVERSION= 0.06
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-alpha-${PORTVERSION}
+
+MAINTAINER= alex@BSDGuru.org
+COMMENT= A forensics tool to examine Thumbs.db files
+
+OPTIONS= IMAGING "Build with ability to extract graphic thumbnails" on
+
+USE_PYTHON= 2.3+
+USE_PYDISTUTILS=yes
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_IMAGING)
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/PIL/_imaging.so:${PORTSDIR}/graphics/py-imaging
+.endif
+
+do-patch:
+ ${REINPLACE_CMD} -e "s|/usr/share/vinetto|${DATADIR}|g" ${WRKSRC}/setup.py
+ ${REINPLACE_CMD} -e "s|/usr/share/vinetto|${DATADIR}|g" ${WRKSRC}/vinreport.py
+ ${REINPLACE_CMD} -e "s|/usr/share/vinetto|${DATADIR}|g" ${WRKSRC}/vinetto
+
+.include <bsd.port.post.mk>
diff --git a/security/vinetto/distinfo b/security/vinetto/distinfo
new file mode 100644
index 000000000000..758f0ecd3ac9
--- /dev/null
+++ b/security/vinetto/distinfo
@@ -0,0 +1,3 @@
+MD5 (vinetto-alpha-0.06.tar.gz) = 6c7fcb1a5111d8517f0b6ae877eab5ff
+SHA256 (vinetto-alpha-0.06.tar.gz) = 6e80e1f1e854bf73507fd122a85a405832ccd122a979b8774612f92a468fd939
+SIZE (vinetto-alpha-0.06.tar.gz) = 15339
diff --git a/security/vinetto/pkg-descr b/security/vinetto/pkg-descr
new file mode 100644
index 000000000000..200106f2ef75
--- /dev/null
+++ b/security/vinetto/pkg-descr
@@ -0,0 +1,16 @@
+Vinetto extracts the thumbnails and associated metadata from the Thumbs.db
+files.
+
+The Windows systems (98, ME, 2000, XP and 2003 Server) can store thumbnails
+and metadata of the picture files contained in the directories of its FAT32
+or NTFS filesystems.
+
+The thumbnails and associated metadata are stored in Thumbs.db files.
+The Thumbs.db files are undocumented OLE structured files.
+
+Once a picture file has been deleted from the filesystem, the related thumbnail
+and associated metada remain stored in the Thumbs.db file. So, the data
+contained in those Thumbs.db files are an helpful source of information
+for the forensics investigator.
+
+WWW: http://vinetto.sourceforge.net/
diff --git a/security/vinetto/pkg-plist b/security/vinetto/pkg-plist
new file mode 100644
index 000000000000..aa4440c8797c
--- /dev/null
+++ b/security/vinetto/pkg-plist
@@ -0,0 +1,12 @@
+bin/vinetto
+lib/%%PYTHON_VERSION%%/site-packages/vinreport.py
+lib/%%PYTHON_VERSION%%/site-packages/vinreport.pyc
+lib/%%PYTHON_VERSION%%/site-packages/vinreport.pyo
+lib/%%PYTHON_VERSION%%/site-packages/vinutils.py
+lib/%%PYTHON_VERSION%%/site-packages/vinutils.pyc
+lib/%%PYTHON_VERSION%%/site-packages/vinutils.pyo
+%%DATADIR%%/HtRepTemplate.html
+%%DATADIR%%/header
+%%DATADIR%%/huffman
+%%DATADIR%%/quantization
+@dirrm %%DATADIR%%