aboutsummaryrefslogtreecommitdiffstats
path: root/security/zenmap/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/zenmap/Makefile')
-rw-r--r--security/zenmap/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/security/zenmap/Makefile b/security/zenmap/Makefile
index 95f5bd83e0eb..96eee0fedef4 100644
--- a/security/zenmap/Makefile
+++ b/security/zenmap/Makefile
@@ -6,20 +6,21 @@
# $FreeBSD$
#
-MASTERDIR= ${.CURDIR}/../nmap
-COMMENT= GUI frontend for the nmap scanning utility
-
PORTNAME= nmapfe
+COMMENT= GUI frontend for the nmap scanning utility
+
RUN_DEPENDS= nmap:${PORTSDIR}/security/nmap
+MASTERDIR= ${.CURDIR}/../nmap
+PLIST= ${.CURDIR}/pkg-plist
+
USE_GNOMENG= yes
USE_GNOME= gtk12
-INSTALL_TARGET= install-nmapfe
+
MAN1= nmapfe.1 xnmap.1
-after-install:
- test -e ${PREFIX}/bin/nmapfe \
- || (cd ${PREFIX}/bin ; ${LN} -f nmapfe xnmap)
+ALL_TARGET= nbase/libnbase.a nmapfe/nmapfe
+INSTALL_TARGET= install-nmapfe
.include "${MASTERDIR}/Makefile"