aboutsummaryrefslogtreecommitdiffstats
path: root/security/zenmap/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/zenmap/Makefile')
-rw-r--r--security/zenmap/Makefile43
1 files changed, 28 insertions, 15 deletions
diff --git a/security/zenmap/Makefile b/security/zenmap/Makefile
index e2694ce34787..bd67890d284c 100644
--- a/security/zenmap/Makefile
+++ b/security/zenmap/Makefile
@@ -1,46 +1,59 @@
-# Ports collection makefile for: zenmap
-# Date created: 2008-01-13
-# Whom: Daniel Roethlisberger <daniel@roe.ch>
-#
+# Created by: Daniel Roethlisberger <daniel@roe.ch>
# $FreeBSD$
-#
PORTNAME= zenmap
PORTVERSION= 6.01
+PORTREVISION= 1
CATEGORIES= security ipv6
MASTER_SITES= http://nmap.org/dist/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= nmap-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
-COMMENT= GUI frontend for the nmap scanning utility
+MAINTAINER= nemysis@gmx.ch
+COMMENT= GUI frontend for the Nmap scanning utility
LICENSE= GPLv2
RUN_DEPENDS= ${LOCALBASE}/bin/nmap:${PORTSDIR}/security/nmap \
${PYTHON_PACKAGENAMEPREFIX}sqlite3>:${PORTSDIR}/databases/py-sqlite3
-WRKSRC= ${WRKDIR}/${DISTNAME}/${PORTNAME}
+WRKSRC= ${WRKDIR}/${DISTNAME}/${PORTNAME}
USE_BZIP2= yes
USE_GNOME= pygtk2
-USE_GETTEXT= yes
USE_PYTHON= 2.5+
-USE_PYDISTUTILS= yes
+USE_PYDISTUTILS=yes
MLINKS= zenmap.1 xnmap.1
-MAN1= zenmap.1 xnmap.1 ndiff.1
+MAN1= zenmap.1 ndiff.1
+
+OPTIONS_DEFINE= NLS
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+PLIST_SUB+= NLS="@comment "
+.endif
post-patch:
- @${REINPLACE_CMD} -e \
- '/self.create_uninstaller/s|^|#|' ${WRKSRC}/setup.py
- @${REINPLACE_CMD} -e \
- 's|share/man/man1|man/man1|' ${WRKSRC}/../ndiff/setup.py
+ @${REINPLACE_CMD} \
+ -e '/self.create_uninstaller/s|^|#|' ${WRKSRC}/setup.py
+ @${REINPLACE_CMD} \
+ -e 's|share/man/man1|man/man1|' ${WRKSRC}/../ndiff/setup.py
+.if ! ${PORT_OPTIONS:MNLS}
+ @${REINPLACE_CMD} -i '' '/locale_dir, mo_find, /d' ${WRKSRC}/setup.py
+.endif
+
post-build:
@(cd ${WRKSRC}/../ndiff \
&& ${PYTHON_CMD} setup.py build)
+
post-install:
${INSTALL_MAN} ${WRKSRC}/../docs/zenmap.1 ${MAN1PREFIX}/man/man1
@(cd ${WRKSRC}/../ndiff \
&& ${PYTHON_CMD} setup.py install --prefix ${PREFIX})
+
.include <bsd.port.mk>