aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
Diffstat (limited to 'security')
-rw-r--r--security/libgnomesu/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/security/libgnomesu/Makefile b/security/libgnomesu/Makefile
index 1ff574cc9660..6e7a919b71ff 100644
--- a/security/libgnomesu/Makefile
+++ b/security/libgnomesu/Makefile
@@ -21,6 +21,10 @@ CONFIGURE_ARGS+=--disable-install-pam
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
+post-patch:
+ @${REINPLACE_CMD} -e 's|-DGTK_DISABLE_DEPRECATED||g' \
+ ${WRKSRC}/src/Makefile.in
+
post-install:
${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${FILESDIR}/gnomesu-pam.sample ${EXAMPLESDIR}