aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-IO-Socket-SSL/Makefile29
-rw-r--r--security/p5-IO-Socket-SSL/distinfo1
-rw-r--r--security/p5-IO-Socket-SSL/pkg-comment1
-rw-r--r--security/p5-IO-Socket-SSL/pkg-descr4
-rw-r--r--security/p5-IO-Socket-SSL/pkg-plist3
6 files changed, 39 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index a988f88d5361..a97d6ccaf433 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -70,6 +70,7 @@
SUBDIR += p5-Crypt-IDEA
SUBDIR += p5-Digest-MD5
SUBDIR += p5-GnuPG-Interface
+ SUBDIR += p5-IO-Socket-SSL
SUBDIR += p5-MD5
SUBDIR += p5-Net-SSLeay
SUBDIR += p5-PGP
diff --git a/security/p5-IO-Socket-SSL/Makefile b/security/p5-IO-Socket-SSL/Makefile
new file mode 100644
index 000000000000..f49c2ba3e10f
--- /dev/null
+++ b/security/p5-IO-Socket-SSL/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-IO-Socket-SSL
+# Date created: October 27th 2000
+# Whom: Marc G. Fournier <scrappy@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= IO-Socket-SSL
+PORTVERSION= 0.75
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= IO
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= scrappy@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Net/SSLeay.pm:${PORTSDIR}/security/p5-Net-SSLeay
+
+RESTRICTED= "Crypto; export-controlled"
+
+USE_PERL5= yes
+
+$MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+$MAN3= IO::Socket::SSL.3
+
+do-configure:
+ @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/security/p5-IO-Socket-SSL/distinfo b/security/p5-IO-Socket-SSL/distinfo
new file mode 100644
index 000000000000..5323764ad937
--- /dev/null
+++ b/security/p5-IO-Socket-SSL/distinfo
@@ -0,0 +1 @@
+MD5 (IO-Socket-SSL-0.75.tar.gz) = 222d1cd2da03f8e93e7283975b5ac173
diff --git a/security/p5-IO-Socket-SSL/pkg-comment b/security/p5-IO-Socket-SSL/pkg-comment
new file mode 100644
index 000000000000..2c90f3e8bb98
--- /dev/null
+++ b/security/p5-IO-Socket-SSL/pkg-comment
@@ -0,0 +1 @@
+Perl5 interface to SSL sockets
diff --git a/security/p5-IO-Socket-SSL/pkg-descr b/security/p5-IO-Socket-SSL/pkg-descr
new file mode 100644
index 000000000000..22c9fc221c05
--- /dev/null
+++ b/security/p5-IO-Socket-SSL/pkg-descr
@@ -0,0 +1,4 @@
+IO::Socket::SSL is a class implementing an object oriented
+interface to SSL sockets. The class is a descendent of
+IO::Socket::INET and provides a subset of the base class's
+interface methods.
diff --git a/security/p5-IO-Socket-SSL/pkg-plist b/security/p5-IO-Socket-SSL/pkg-plist
new file mode 100644
index 000000000000..6bafbeaed36c
--- /dev/null
+++ b/security/p5-IO-Socket-SSL/pkg-plist
@@ -0,0 +1,3 @@
+lib/perl5/site_perl/%%PERL_VER%%/IO/Socket/SSL.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/IO/Socket/SSL/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/IO/Socket/SSL
te to 2.5.2.avilla2012-09-172-4/+4 * - Update Calligra to 2.5.1.avilla2012-09-014-14/+4 * The KDE/FreeBSD team is pleased to announce version 2.5 of Calligra,avilla2012-08-264-30/+6 * - Update to 3.5.6.jkim2012-08-242-8/+8 * - Fix typos in COMMENTcs2012-08-021-1/+1 * - Update LibreOffice and the language packs to 3.5.5.jkim2012-07-182-8/+8 * - Update to 20120711sunpoet2012-07-132-3/+3 * - Update Calligra to 2.4.3.avilla2012-07-052-4/+4 * - The FreeBSD Office team is proud to announce LibreOffice.org 3.5.4 releasefluffy2012-07-012-8/+8 * - Update to 20120611sunpoet2012-06-182-3/+3 * KDE/FreeBSD team presents KDE SC 4.8.4, probably the last release in 4.8.x se...makc2012-06-155-6/+18 * - update png to 1.5.10dinoex2012-06-014-2/+4 * - Remove koffice-i18n ports, as they are not very useful withoutavilla2012-05-319-794/+0 * The KDE/FreeBSD team is pleased to announce Calligra Suite 2.4.2, KDEavilla2012-05-3117-502/+151 * KDE/FreeBSD team presents long awaited KDE SC 4.8.3!makc2012-05-258-56/+206 * - Update to 20120503sunpoet2012-05-062-3/+3 * - upgrade to 3.5.2bapt2012-04-237-0/+44 * - Update to 20120312sunpoet2012-03-142-3/+3 * - Bump PORTREVISION to chase the update of multimedia/libvpxashish2012-02-162-0/+2 * The KDE/FreeBSD team is pleased to announce KDE SC 4.7.4, whichavilla2012-01-253-5/+5 * - Update to 20120118sunpoet2012-01-222-3/+3 * - Update to 20120112sunpoet2012-01-132-3/+3 * - Update to 20111225sunpoet2011-12-282-3/+3 * - Update to 20111207sunpoet2011-12-082-3/+3 * - Update to 20111204sunpoet2011-12-072-3/+3 * - Pass maintainership to office@FreeBSD.orgsunpoet2011-11-292-2/+2 * - Update to 20111126sunpoet2011-11-282-3/+3 * - Update to 20111119sunpoet2011-11-212-3/+3 * The KDE on FreeBSD team is pleased to update the KDE4 ports to 4.7.3.rakuco2011-11-142-4/+4 * - Update to 20111102sunpoet2011-11-072-3/+3 * - Update to 20111025sunpoet2011-10-302-3/+3 * The vast majority of pkg-descr files had the following format when theydougb2011-10-241-2/+0 * The KDE/FreeBSD team is pleased to announce KDE Software Compilationavilla2011-10-175-37/+270 * - Update to 20110928sunpoet2011-10-032-3/+3 * - Update to 20110909sunpoet2011-09-192-3/+3 * - Set DIST_SUBDIR: move dist files to DISTDIR/mythessunpoet2011-08-182-2/+3 * - Set DIST_SUBDIR: move dist files to DISTDIR/hyphensunpoet2011-08-182-2/+3 * - Set DIST_SUBDIR: move dist files to DISTDIR/hunspellsunpoet2011-08-182-4/+5 * - Change MASTER_SITES to my LOCAL to avoid implicit change of non-versionedsunpoet2011-08-184-8/+8 * - Update to 20110814sunpoet2011-08-162-3/+3 * - Update to 20110813sunpoet2011-08-152-4/+3 * - Set WRKSRCsunpoet2011-08-131-1/+2 * - Unify COMMENT and pkg-descrsunpoet2011-08-132-2/+2 * - Use WRKSRCsunpoet2011-08-121-1/+1 * Remove WWW entries from unmaintained ports that return 404 or where the domainehaupt2011-08-031-2/+0 * - Move language prefix to PKGNAMEPREFIXsunpoet2011-07-293-29/+29 * - Fix typosunpoet2011-07-251-1/+1 * Pass matainership to the new office teambapt2011-07-223-3/+3 * Add some locales thesaurusbapt2011-07-214-0/+41 * Add Portuguese hyphenation rulesbapt2011-07-214-0/+35 * Add portuguese and bresilian hunspell dictionnarybapt2011-07-204-0/+49 * Reset maintainership de jure. In fact KDE 3 has not been maintained by our teammakc2011-07-084-4/+4 * Update KDE Software Compilation ports to 4.6.5makc2011-07-085-5/+195 * - remove MD5ohauer2011-07-03