aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/op/Makefile30
-rw-r--r--security/op/distinfo3
-rw-r--r--security/op/pkg-descr6
-rw-r--r--security/op/pkg-plist5
5 files changed, 45 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 7d3930355647..995b5c2c9c18 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -301,6 +301,7 @@
SUBDIR += ocaml-ssl
SUBDIR += oidentd
SUBDIR += oinkmaster
+ SUBDIR += op
SUBDIR += openbsm
SUBDIR += opencdk
SUBDIR += openct
diff --git a/security/op/Makefile b/security/op/Makefile
new file mode 100644
index 000000000000..ef9eea421ec3
--- /dev/null
+++ b/security/op/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: op
+# Date created: 30 Sep 2008
+# Whom: Emanuel Haupt <ehaupt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= op
+PORTVERSION= 1.32
+CATEGORIES= security
+MASTER_SITES= http://swapoff.org/files/op/ \
+ CRITICAL
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Controlled privilege escalation tool
+
+GNU_CONFIGURE= yes
+
+MAN1= op.1
+
+post-install:
+ ${MKDIR} ${PREFIX}/etc/op.d
+ ${INSTALL_DATA} -m 0600 ${WRKSRC}/${PORTNAME}.conf \
+ ${PREFIX}/etc/${PORTNAME}.conf.sample
+
+.if !exists(${PREFIX}/etc/${PORTNAME}.conf)
+ ${INSTALL_DATA} -m 0600 ${WRKSRC}/${PORTNAME}.conf ${PREFIX}/etc
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/op/distinfo b/security/op/distinfo
new file mode 100644
index 000000000000..fdc7cae315bc
--- /dev/null
+++ b/security/op/distinfo
@@ -0,0 +1,3 @@
+MD5 (op-1.32.tar.gz) = 795b0ffabd305d48288aff46542fe3bf
+SHA256 (op-1.32.tar.gz) = 520d330ad7bb038d0719a3ea0304795311de219cf1def8d141097692147d5632
+SIZE (op-1.32.tar.gz) = 145682
diff --git a/security/op/pkg-descr b/security/op/pkg-descr
new file mode 100644
index 000000000000..0c9484da19fb
--- /dev/null
+++ b/security/op/pkg-descr
@@ -0,0 +1,6 @@
+The op tool provides a flexible means for system administrators to grant access
+to certain root operations without having to give them full superuser
+privileges. Different sets of users may access different operations, and the
+security-related aspects of each operation can be carefully controlled.
+
+WWW: http://svn.swapoff.org/op/
diff --git a/security/op/pkg-plist b/security/op/pkg-plist
new file mode 100644
index 000000000000..de4747e2dfe7
--- /dev/null
+++ b/security/op/pkg-plist
@@ -0,0 +1,5 @@
+@unexec if cmp -s %D/etc/op.conf %D/etc/op.conf.sample; then rm -f %D/etc/op.conf; fi
+etc/op.conf.sample
+@exec [ -f %B/op.conf ] || cp %B/%f %B/op.conf
+bin/op
+@dirrmtry etc/op.d