aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/mbedtls/Makefile35
-rw-r--r--security/mbedtls/distinfo2
-rw-r--r--security/mbedtls/pkg-descr4
-rw-r--r--security/mbedtls/pkg-plist114
5 files changed, 156 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index da6f412ee507..96036ae8103b 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -335,6 +335,7 @@
SUBDIR += masscan
SUBDIR += massh
SUBDIR += matrixssl
+ SUBDIR += mbedtls
SUBDIR += mcrypt
SUBDIR += md4coll
SUBDIR += md5coll
diff --git a/security/mbedtls/Makefile b/security/mbedtls/Makefile
new file mode 100644
index 000000000000..3f373ba00e20
--- /dev/null
+++ b/security/mbedtls/Makefile
@@ -0,0 +1,35 @@
+# $FreeBSD$
+
+PORTNAME= mbedtls
+PORTVERSION= 2.0.0
+DISTVERSIONSUFFIX= -gpl
+CATEGORIES= security devel
+MASTER_SITES= https://tls.mbed.org/download/
+
+MAINTAINER= tijl@FreeBSD.org
+COMMENT= SSL/TLS and cryptography library
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+ALL_TARGET= no_test
+MAKE_ENV= SHARED=1
+USES= gmake tar:tgz
+USE_LDCONFIG= yes
+
+WRKSRC= ${WRKDIR}/mbedtls-${PORTVERSION}
+
+CONFLICTS_INSTALL= polarssl13-[0-9]*
+
+post-patch:
+ @${REINPLACE_CMD} \
+ -e 's/PREFIX/NAMEPREFIX/' \
+ -e 's/$$(DESTDIR)/&$$(PREFIX)/' \
+ -e '/^install:/s/[[:<:]]all//' \
+ ${WRKSRC}/Makefile
+
+post-install:
+ ${FIND} ${STAGEDIR}${PREFIX}/bin ${STAGEDIR}${PREFIX}/lib -type f | \
+ ${XARGS} ${STRIP_CMD}
+
+.include <bsd.port.mk>
diff --git a/security/mbedtls/distinfo b/security/mbedtls/distinfo
new file mode 100644
index 000000000000..7a894ff4a27d
--- /dev/null
+++ b/security/mbedtls/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mbedtls-2.0.0-gpl.tgz) = 149a06621368540b7e1cef1b203c268439c2edbf29e2e9471d8021125df34952
+SIZE (mbedtls-2.0.0-gpl.tgz) = 1790002
diff --git a/security/mbedtls/pkg-descr b/security/mbedtls/pkg-descr
new file mode 100644
index 000000000000..8901bb50743e
--- /dev/null
+++ b/security/mbedtls/pkg-descr
@@ -0,0 +1,4 @@
+mbed TLS is a lightweight, portable, fully featured and standards compliant
+SSL/TLS and cryptography library.
+
+WWW: https://tls.mbed.org/
diff --git a/security/mbedtls/pkg-plist b/security/mbedtls/pkg-plist
new file mode 100644
index 000000000000..ac37b2cbe48e
--- /dev/null
+++ b/security/mbedtls/pkg-plist
@@ -0,0 +1,114 @@
+bin/mbedtls_aescrypt2
+bin/mbedtls_benchmark
+bin/mbedtls_cert_app
+bin/mbedtls_cert_req
+bin/mbedtls_cert_write
+bin/mbedtls_crl_app
+bin/mbedtls_crypt_and_hash
+bin/mbedtls_dh_client
+bin/mbedtls_dh_genprime
+bin/mbedtls_dh_server
+bin/mbedtls_dtls_client
+bin/mbedtls_dtls_server
+bin/mbedtls_ecdsa
+bin/mbedtls_gen_entropy
+bin/mbedtls_gen_key
+bin/mbedtls_gen_random_ctr_drbg
+bin/mbedtls_gen_random_havege
+bin/mbedtls_generic_sum
+bin/mbedtls_hello
+bin/mbedtls_key_app
+bin/mbedtls_key_app_writer
+bin/mbedtls_mini_client
+bin/mbedtls_mpi_demo
+bin/mbedtls_pem2der
+bin/mbedtls_pk_decrypt
+bin/mbedtls_pk_encrypt
+bin/mbedtls_pk_sign
+bin/mbedtls_pk_verify
+bin/mbedtls_req_app
+bin/mbedtls_rsa_decrypt
+bin/mbedtls_rsa_encrypt
+bin/mbedtls_rsa_genkey
+bin/mbedtls_rsa_sign
+bin/mbedtls_rsa_sign_pss
+bin/mbedtls_rsa_verify
+bin/mbedtls_rsa_verify_pss
+bin/mbedtls_selftest
+bin/mbedtls_ssl_cert_test
+bin/mbedtls_ssl_client1
+bin/mbedtls_ssl_client2
+bin/mbedtls_ssl_fork_server
+bin/mbedtls_ssl_mail_client
+bin/mbedtls_ssl_server
+bin/mbedtls_ssl_server2
+bin/mbedtls_strerror
+bin/mbedtls_udp_proxy
+include/mbedtls/aes.h
+include/mbedtls/aesni.h
+include/mbedtls/arc4.h
+include/mbedtls/asn1.h
+include/mbedtls/asn1write.h
+include/mbedtls/base64.h
+include/mbedtls/bignum.h
+include/mbedtls/blowfish.h
+include/mbedtls/bn_mul.h
+include/mbedtls/camellia.h
+include/mbedtls/ccm.h
+include/mbedtls/certs.h
+include/mbedtls/check_config.h
+include/mbedtls/cipher.h
+include/mbedtls/cipher_internal.h
+include/mbedtls/compat-1.3.h
+include/mbedtls/config.h
+include/mbedtls/ctr_drbg.h
+include/mbedtls/debug.h
+include/mbedtls/des.h
+include/mbedtls/dhm.h
+include/mbedtls/ecdh.h
+include/mbedtls/ecdsa.h
+include/mbedtls/ecp.h
+include/mbedtls/entropy.h
+include/mbedtls/entropy_poll.h
+include/mbedtls/error.h
+include/mbedtls/gcm.h
+include/mbedtls/havege.h
+include/mbedtls/hmac_drbg.h
+include/mbedtls/md.h
+include/mbedtls/md2.h
+include/mbedtls/md4.h
+include/mbedtls/md5.h
+include/mbedtls/md_internal.h
+include/mbedtls/memory_buffer_alloc.h
+include/mbedtls/net.h
+include/mbedtls/oid.h
+include/mbedtls/padlock.h
+include/mbedtls/pem.h
+include/mbedtls/pk.h
+include/mbedtls/pk_internal.h
+include/mbedtls/pkcs11.h
+include/mbedtls/pkcs12.h
+include/mbedtls/pkcs5.h
+include/mbedtls/platform.h
+include/mbedtls/ripemd160.h
+include/mbedtls/rsa.h
+include/mbedtls/sha1.h
+include/mbedtls/sha256.h
+include/mbedtls/sha512.h
+include/mbedtls/ssl.h
+include/mbedtls/ssl_cache.h
+include/mbedtls/ssl_ciphersuites.h
+include/mbedtls/ssl_cookie.h
+include/mbedtls/ssl_internal.h
+include/mbedtls/ssl_ticket.h
+include/mbedtls/threading.h
+include/mbedtls/timing.h
+include/mbedtls/version.h
+include/mbedtls/x509.h
+include/mbedtls/x509_crl.h
+include/mbedtls/x509_crt.h
+include/mbedtls/x509_csr.h
+include/mbedtls/xtea.h
+lib/libmbedtls.a
+lib/libmbedtls.so
+lib/libmbedtls.so.10