aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
Diffstat (limited to 'security')
-rw-r--r--security/clamav-devel/Makefile7
-rw-r--r--security/clamav/Makefile7
2 files changed, 2 insertions, 12 deletions
diff --git a/security/clamav-devel/Makefile b/security/clamav-devel/Makefile
index 3cb55ff82068..bfb38e60a431 100644
--- a/security/clamav-devel/Makefile
+++ b/security/clamav-devel/Makefile
@@ -52,6 +52,7 @@ CONFIGURE_ARGS= --with-dbdir=${DBDIR} \
--enable-bigstack \
--enable-readdir_r \
--disable-dependency-tracking \
+ --enable-gethostbyname_r \
--enable-experimental
CPPFLAGS+= -I${LOCALBASE}/include \
${PTHREAD_CFLAGS}
@@ -102,12 +103,6 @@ PLIST_SUB+= CLAMAVUSER=${CLAMAVUSER} \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 601103
-CONFIGURE_ARGS+= --disable-gethostbyname_r
-.else
-CONFIGURE_ARGS+= --enable-gethostbyname_r
-.endif
-
# This port has a problem with -pthread,
# force to use -lthr until it's not fixed.
.if ${OSVERSION} >= 601000
diff --git a/security/clamav/Makefile b/security/clamav/Makefile
index 73793167ee02..0af57b9282a7 100644
--- a/security/clamav/Makefile
+++ b/security/clamav/Makefile
@@ -47,6 +47,7 @@ CONFIGURE_ARGS= --with-dbdir=${DBDIR} \
--disable-clamav \
--enable-bigstack \
--enable-readdir_r \
+ --enable-gethostbyname_r \
--disable-dependency-tracking
CPPFLAGS+= -I${LOCALBASE}/include \
${PTHREAD_CFLAGS}
@@ -97,12 +98,6 @@ PLIST_SUB+= CLAMAVUSER=${CLAMAVUSER} \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 601103
-CONFIGURE_ARGS+= --disable-gethostbyname_r
-.else
-CONFIGURE_ARGS+= --enable-gethostbyname_r
-.endif
-
# This port has a problem with -pthread,
# force to use -lthr until it's not fixed.
.if ${OSVERSION} >= 601000