aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
Diffstat (limited to 'security')
-rw-r--r--security/p5-Authen-DecHpwd/Makefile6
-rw-r--r--security/p5-Authen-Passphrase/Makefile22
-rw-r--r--security/p5-Crypt-Eksblowfish/Makefile4
3 files changed, 16 insertions, 16 deletions
diff --git a/security/p5-Authen-DecHpwd/Makefile b/security/p5-Authen-DecHpwd/Makefile
index 6b112617f0ee..13f8785ea9aa 100644
--- a/security/p5-Authen-DecHpwd/Makefile
+++ b/security/p5-Authen-DecHpwd/Makefile
@@ -14,9 +14,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= brix@FreeBSD.org
COMMENT= Perl module for DEC VMS password hashing
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Scalar/String.pm:${PORTSDIR}/devel/p5-Scalar-String \
- ${SITE_PERL}/Data/Integer.pm:${PORTSDIR}/devel/p5-Data-Integer \
- ${SITE_PERL}/${PERL_ARCH}/Digest/CRC.pm:${PORTSDIR}/security/p5-Digest-CRC
+BUILD_DEPENDS= p5-Scalar-String>=0:${PORTSDIR}/devel/p5-Scalar-String \
+ p5-Data-Integer>=0:${PORTSDIR}/devel/p5-Data-Integer \
+ p5-Digest-CRC>=0:${PORTSDIR}/security/p5-Digest-CRC
RUN_DEPENDS:= ${BUILD_DEPENDS}
LICENSE= GPLv2
diff --git a/security/p5-Authen-Passphrase/Makefile b/security/p5-Authen-Passphrase/Makefile
index 5461e6f9bc06..6b3773d9872c 100644
--- a/security/p5-Authen-Passphrase/Makefile
+++ b/security/p5-Authen-Passphrase/Makefile
@@ -17,17 +17,17 @@ COMMENT= Perl module for handling hashed passwords/passphrases as objects
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Authen/DecHpwd.pm:${PORTSDIR}/security/p5-Authen-DecHpwd \
- ${SITE_PERL}/${PERL_ARCH}/Crypt/Blowfish.pm:${PORTSDIR}/security/p5-Crypt-Blowfish \
- ${SITE_PERL}/${PERL_ARCH}/Crypt/DES.pm:${PORTSDIR}/security/p5-Crypt-DES \
- ${SITE_PERL}/${PERL_ARCH}/Crypt/Eksblowfish.pm:${PORTSDIR}/security/p5-Crypt-Eksblowfish \
- ${SITE_PERL}/${PERL_ARCH}/Crypt/MySQL.pm:${PORTSDIR}/security/p5-Crypt-MySQL \
- ${SITE_PERL}/Crypt/PasswdMD5.pm:${PORTSDIR}/security/p5-Crypt-PasswdMD5 \
- ${SITE_PERL}/${PERL_ARCH}/Crypt/UnixCrypt_XS.pm:${PORTSDIR}/security/p5-Crypt-UnixCrypt_XS \
- ${SITE_PERL}/Data/Entropy/Algorithms.pm:${PORTSDIR}/security/p5-Data-Entropy \
- ${SITE_PERL}/${PERL_ARCH}/Digest/MD4.pm:${PORTSDIR}/security/p5-Digest-MD4 \
- ${SITE_PERL}/Module/Runtime.pm:${PORTSDIR}/devel/p5-Module-Runtime \
- ${SITE_PERL}/${PERL_ARCH}/Params/Classify.pm:${PORTSDIR}/devel/p5-Params-Classify
+BUILD_DEPENDS= p5-Authen-DecHpwd>=0:${PORTSDIR}/security/p5-Authen-DecHpwd \
+ p5-Crypt-Blowfish>=0:${PORTSDIR}/security/p5-Crypt-Blowfish \
+ p5-Crypt-DES>=0:${PORTSDIR}/security/p5-Crypt-DES \
+ p5-Crypt-Eksblowfish>=0:${PORTSDIR}/security/p5-Crypt-Eksblowfish \
+ p5-Crypt-MySQL>=0:${PORTSDIR}/security/p5-Crypt-MySQL \
+ p5-Crypt-PasswdMD5>=0:${PORTSDIR}/security/p5-Crypt-PasswdMD5 \
+ p5-Crypt-UnixCrypt_XS>=0:${PORTSDIR}/security/p5-Crypt-UnixCrypt_XS \
+ p5-Data-Entropy>=0:${PORTSDIR}/security/p5-Data-Entropy \
+ p5-Digest-MD4>=0:${PORTSDIR}/security/p5-Digest-MD4 \
+ p5-Module-Runtime>=0:${PORTSDIR}/devel/p5-Module-Runtime \
+ p5-Params-Classify>=0:${PORTSDIR}/devel/p5-Params-Classify
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_MODBUILD= yes
diff --git a/security/p5-Crypt-Eksblowfish/Makefile b/security/p5-Crypt-Eksblowfish/Makefile
index c0ef6e93cbe9..d034d9849774 100644
--- a/security/p5-Crypt-Eksblowfish/Makefile
+++ b/security/p5-Crypt-Eksblowfish/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= brix@FreeBSD.org
COMMENT= Perl module for the Eksblowfish block cipher
-RUN_DEPENDS= ${SITE_PERL}/Class/Mix.pm:${PORTSDIR}/devel/p5-Class-Mix \
- ${SITE_PERL}/parent.pm:${PORTSDIR}/devel/p5-parent
+RUN_DEPENDS= p5-Class-Mix>=0:${PORTSDIR}/devel/p5-Class-Mix \
+ p5-parent>=0:${PORTSDIR}/devel/p5-parent
LICENSE_COMB= dual
LICENSE= ART10 GPLv1