aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
Diffstat (limited to 'security')
-rw-r--r--security/openssh-askpass/Makefile6
-rw-r--r--security/openssh-askpass/files/Makefile.in5
2 files changed, 8 insertions, 3 deletions
diff --git a/security/openssh-askpass/Makefile b/security/openssh-askpass/Makefile
index 7fd58e3062f4..0738399e515e 100644
--- a/security/openssh-askpass/Makefile
+++ b/security/openssh-askpass/Makefile
@@ -3,7 +3,7 @@
PORTNAME= OpenSSH-askpass
PORTVERSION= 1.2.4.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= http://www.jmknoble.net/software/x11-ssh-askpass/
DISTNAME= x11-ssh-askpass-${PORTVERSION}
@@ -11,12 +11,16 @@ DISTNAME= x11-ssh-askpass-${PORTVERSION}
MAINTAINER= hrs@FreeBSD.org
COMMENT= Graphical password applet for entering SSH passphrase
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/README
+
USE_XORG= x11 xt sm ice
DOCSDIR= ${PREFIX}/share/doc/ssh-askpass
PLIST_FILES= bin/x11-ssh-askpass \
bin/ssh-askpass \
lib/X11/app-defaults/SshAskpass
PORTDOCS= README TODO ChangeLog
+MAKE_JOBS_SAFE= yes
MAN1= x11-ssh-askpass.1
MLINKS= x11-ssh-askpass.1 ssh-askpass.1
diff --git a/security/openssh-askpass/files/Makefile.in b/security/openssh-askpass/files/Makefile.in
index 53cfa35066cb..988b1af39511 100644
--- a/security/openssh-askpass/files/Makefile.in
+++ b/security/openssh-askpass/files/Makefile.in
@@ -17,6 +17,8 @@ LDADD= -lXt -lX11 -lSM -lICE -L${LOCALBASE}/lib -Wl,-rpath,${LOCALBASE}/lib
CFLAGS+=-I${LOCALBASE}/include -DCSRG_BASED -DFUNCPROTO=15 -DNARROWPROTO
MAN= ${PROG}.1
+x11-ssh-askpass.o: ${CLASS}_ad.h
+
${PROG}.1: x11-ssh-askpass.man.in
sed -e 's|@NAME@|${PROG}|' \
-e 's|@DATE@|September 17, 2001|'\
@@ -30,8 +32,7 @@ ${CLASS}.ad: ${CLASS}-default.ad
cp $? $@
${CLASS}_ad.h: ${CLASS}.ad
- sed -n '/^[^!]/s/.*/"&",/p' < $? >$@.tmp
- mv $@.tmp $@
+ sed -n '/^[^!]/s/.*/"&",/p' < $? > $@ || (rm -f $@; false)
${PROG}: ${CLASS}_ad.h
CLEANFILES+= ${CLASS}_ad.h