aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
Diffstat (limited to 'security')
-rw-r--r--security/clamav/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/security/clamav/Makefile b/security/clamav/Makefile
index b92c3d86a958..442498d8a805 100644
--- a/security/clamav/Makefile
+++ b/security/clamav/Makefile
@@ -141,6 +141,8 @@ SED_CONF= -E -e 's|^\#?(Example)$$|\#\1|' \
-e 's|^\#?(MilterSocket) */tmp.*$$|\1 ${CLAMAV_MILTER_SOCKET}|' \
-e 's|^\#?(ClamdSocket).*$$|\1 unix:${CLAMAV_CLAMD_SOCKET}|'
+.include <bsd.port.pre.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|-lthr|g' \
-e 's|LC_REVISION=22|LC_REVISION=24|' \
@@ -149,6 +151,13 @@ post-patch:
${WRKSRC}/etc/clamd.conf.sample \
${WRKSRC}/etc/freshclam.conf.sample \
${WRKSRC}/etc/clamav-milter.conf.sample
+.if exists(/usr/lib/libstdc++.so)
+ @${REINPLACE_CMD} -e 's|-Wno-logical-op-parentheses||' \
+ -e 's|-Wno-dangling-else||' \
+ ${WRKSRC}/libclamav/Makefile.am \
+ ${WRKSRC}/libclamav/Makefile.in \
+ ${WRKSRC}/libclamunrar/makefile
+.endif
pre-configure-TESTS-on:
@if ! ${PYTHON_CMD} -c "import thread" >/dev/null 2>&1; then \
@@ -174,4 +183,4 @@ post-install:
${STAGEDIR}${RUNDIR}
(cd ${WRKSRC}/docs/html; ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}/html)
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>